1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Check out the 6 new Certified Incredible PBX Builds for Asterisk 11 and 13 featuring CentOS 6, Ubuntu 14, Raspberry Pi 2, and Asterisk-NOW.
    Dismiss Notice

CID Superfecta + FreePBX 2.9

Discussion in 'Bug Reporting and Fixes' started by bpps, Feb 15, 2011.

  1. bpps

    bpps New Member

    freepbx 2.9
    superfecta 2.2.4

    debuging a number returns

    Fatal error: Call to undefined function parse_amportal_conf() in /var/www/html/admin/modules/superfecta/bin/callerid.php on line 46

  2. tshif

    tshif Guru

    CallerID Superfecta is NOT presently compatible with FreePBX 2.9.
  3. Easy fix

    --- callerid.php 2010-12-22 07:37:22.000000000 +0100
    +++ bin/callerid.php 2011-02-16 08:21:20.000000000 +0100
    @@ -8,6 +8,9 @@
    8-18-2009 Version 2.2.0 CID Schemes and online update for data sources (projects.colsolgrp.net)(jjacobs)
    10-26-2009 Version 2.2.2 http://projects.colsolgrp.net/versions/show/55 (projects.colsolgrp.net) (patrick_elx)
    +if (!@include_once(getenv('FREEPBX_CONF') ? getenv('FREEPBX_CONF') : '/etc/freepbx.conf')) {
    + include_once('/etc/asterisk/freepbx.conf');

    $debug_val = (isset($_REQUEST['debug'])) ? $_REQUEST['debug'] : '';
    $debug = ($debug_val == 'yes') ? true : false;
    @@ -17,7 +20,7 @@
    ini_set('display_errors', '1');

    +// require_once("../../../functions.inc.php");

    $caller_id = '';
    $charsetIA5 = true;
    @@ -40,10 +43,11 @@

    // new code - causes config values to be pulled from db 3/12/2009
    -require_once 'DB.php';
    -define("AMP_CONF", "/etc/amportal.conf");
    +// require_once 'DB.php';
    +//define("AMP_CONF", "/etc/amportal.conf");
    +//$amp_conf = parse_amportal_conf(AMP_CONF);

    -$amp_conf = parse_amportal_conf(AMP_CONF);
    if(count($amp_conf) == 0)
    @@ -64,7 +68,7 @@

    //connect to the asterisk manager
    +// require_once('../../../common/php-asmanager.php');
    $astman = new AGI_AsteriskManager();

    // attempt to connect to asterisk manager proxy
  4. ustelephone

    ustelephone Member

    I tried to post this at http://projects.colsolgrp.net/issues/503 but I can not get access.

    FYI on the topic, when I do a debug I get no change on the screen or error, just area.

    Attached is a shot after hitting the debug button.

    Attached Files:

  5. kenn10

    kenn10 Guru-ish

    I had to create a login to their site to get the new callerid_29.php program. They have corrected the program to work with FreePBX 2.9 but have not done a general release just yet.
  6. Just a suggestion … if you wanted to house this over on the FreePBX SVN repository you might get more eyes on it, and fixes like mickecarlsson provided by other FreePBX developers would simply get checked in and updated right away.

    Anyhow - the options is always there. The Endpoint manager got moved there and that resulted in huge amounts of exposure and suggestions/collaboration not only with FreePBX but as a result with other projects as well...
  7. tm1000

    tm1000 Schmoozecom INC/FreePBX

    I got rid of callerid_29.php. I incorporated all of the changes needed into callerid.php

  8. ajmorris

    ajmorris New Member

    How do download the fix?

  9. lgaetz

    lgaetz Pundit

    Assuming you have the latest version (ver. 2.2.4) of Superfecta installed then you need to download this file: *link removed*

    On your PIAF server, find:

    and rename it so you have a backup you can undo if necessary. Copy the file downloaded above to that same folder. Change ownership of the uploaded file to asterisk:asterisk and permissions to: 0774.

    * There is no need to patch 2.2.4 any more, upgrade to Superfecta 2.2.5
  10. ajmorris

    ajmorris New Member

    Okay, i do have the latest version and downloaded the callerid.php file and set all the permissions but now when i go to debug a number i get is "Detected FreePBX version is at least 2.9" and that's all? any thoughts?

  11. tm1000

    tm1000 Schmoozecom INC/FreePBX



    tail -f /var/log/httpd/error_log
    Then run the debug again and post the error here.
  12. ajmorris

    ajmorris New Member

    Still doing the same thing. Had an error in the Httpd log about the pbdirectory and the sounds file not having permissions but i have fixed and updated that module so that's good, just the superfecta isn't working....any other thoughts?

    here is the log...

    tail -f /var/log/httpd/error_log
    [Thu Mar 10 16:46:16 2011] [notice] Digest: done
    [Thu Mar 10 16:46:16 2011] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
    [Thu Mar 10 17:48:23 2011] [error] [client] script not found or unable to stat: /var/www/cgi-bin/awstats.pl
    [Thu Mar 10 17:48:44 2011] [error] [client] script not found or unable to stat: /var/www/cgi-bin/awstats.pl
    rm: cannot chdir from `/var/www/html/admin/modules/pbdirectory/sounds' to `pbdirectory': Permission denied
    [Fri Mar 11 07:10:42 2011] [notice] caught SIGTERM, shutting down
    [Fri Mar 11 07:12:44 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Fri Mar 11 07:12:44 2011] [notice] Digest: generating secret for digest authentication ...
    [Fri Mar 11 07:12:44 2011] [notice] Digest: done
    [Fri Mar 11 07:12:45 2011] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
  13. tm1000

    tm1000 Schmoozecom INC/FreePBX

    There are no errors in your log so unfortunately I can't tell you whats wrong...

  14. ajmorris

    ajmorris New Member

    Yeah. I am not sure what's going on either. Everything else looks good. I even reinstalled the superfecta module and re-downloaded the new callerid.php file. Still no go. Is there anything else that i need to try?


    Do you all have a working superfecta?
  15. ustelephone

    ustelephone Member



    I'm still without. I made it to the link r573 that states it will fix it, but I can not log in. I create new profiles, request a new password, and nothing.

    Anyone able to send me the file or provide an url?
  16. tm1000

    tm1000 Schmoozecom INC/FreePBX

  17. ustelephone

    ustelephone Member

    I bow in the thanks!

    I am up and working. I simply replaced the file and it works. No modifications to security or reinstalling anything.

    Many, many thanks.
  18. ustelephone

    ustelephone Member

    Real quick update .. I tested the Superfecta last night middle of the night, and it is working. This morning I noticed that I couldn't hear anyone on incoming calls. I did a restart of the box, nothing. Then I disabled Superfecta from the trunks and everything's working.

    I will go through the logs tonight and either try to fix or post what I find. I just didn't want anyone seeing my last post any making a move; I still have issues.

    Will post tonight after testing.
  19. tm1000

    tm1000 Schmoozecom INC/FreePBX

    I linked you to the callerid.php for the 2.2.4 version.

    Sounds like you are using the 2.3.x version

    Please confirm

  20. ustelephone

    ustelephone Member

    Version 2.2.3

Share This Page