1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Cisco 7960 registration problem

Discussion in 'Endpoints' started by vinod, Mar 16, 2009.

  1. vinod New Member

    Cisco 7960 incoming problem

    Hi

    I am using Cisco SIP firmware version P0S3-08-8-00 for my Cisco 7930 IP Phone.

    I am using the following values for SIPDefault.cnf

    Code:
    ; sip default configuration file
    #Image Version
    image_version:P0S3-08-8-00 ;
    #Proxy server address
    proxy1_address: [I]asteriskipaddress[/I] ; 
    proxy_register: 1;
    nat_enable: 1
    nat_address: [I]ip-phone-gateway-ip-address[/I]
    nat_received_processing: 1
    I've successfully managed to make calls using Cisco 7960 IP phone.

    But the problem is the account is not registered with the server. I think authentication is done only at the time of calling.

    Can someone please advice me where i am going wrong with my setup.


    Thanks in advance
    Vino
  2. vinod New Member

    The phone is now registered.

    But the problem is, incoming calls to the Cisco phone is directly going to the extension voicemail. But outgoing from the phone is perfect.

    Can anyone please help me to sort it out?

    Thanks
    Vino
  3. jpe Member

    Do you have a phone config file in the tftpboot folder?

    here is a template from my setup

    Code:
    # SIP Configuration Generic File (start)
    
    # Line 1 Settings
    line1_name: "201"                     ; Line 1 Extension\User ID
    line1_shortname: "(000) 000-0000"		 ; Line 1 Display Name
    line1_displayname: "0000000000"           ; Line 1 CID Display
    line1_authname: "201"         ; Line 1 Registration Authentication
    line1_password: "0000"         ; Line 1 Registration Password
    
    # Line 2 Settings
    line2_name: ""                    ; Line 2 Extension\User ID
    line2_shortname: ""		 ; Line 2 Display Name 
    line2_displayname: ""                ; Line 2 CID Display
    line2_authname: ""         ; Line 2 Registration Authentication
    line2_password: ""         ; Line 2 Registration Password
    
    # Line 3 Settings
    line3_name: ""                          ; Line 3 Extension\User ID
    line3_shortname: ""		 ; Line 3 Display Name
    line3_displayname: ""                   ; Line 3 CID Display
    line3_authname: ""         ; Line 3 Registration Authentication
    line3_password: "UNPROVISIONED"         ; Line 3 Registration Password
    
    # Line 4 Settings
    line4_name: ""                          ; Line 4 Extension\User ID
    line4_shortname: ""		 ; Line 4 Display Name
    line4_displayname: ""                   ; Line 4 CID Display
    line4_authname: ""         ; Line 4 Registration Authentication
    line4_password: "UNPROVISIONED"         ; Line 4 Registration Password
    
    # Line 5 Settings
    line5_name: ""                          ; Line 5 Extension\User ID
    line5_shortname: ""		 ; Line 5 Display Name
    line5_displayname: ""                   ; Line 5 CID Display
    line5_authname: ""         ; Line 5 Registration Authentication
    line5_password: "UNPROVISIONED"         ; Line 5 Registration Password
    
    # Line 6 Settings
    line6_name: ""                          ; Line 6 Extension\User ID
    line6_shortname: ""		 ; Line 6 Display Name
    line6_displayname: ""                   ; Line 6 CID Display
    line6_authname: ""         ; Line 6 Registration Authentication
    line6_password: "UNPROVISIONED"         ; Line 6 Registration Password
    
    # NAT/Firewall Traversal
    nat_address: ""
    voip_control_port: "5060"
    start_media_port: "16384"
    end_media_port:  "32766"
    
    
    # Phone Label (Text desired to be displayed in upper right corner)
    phone_label: ""            ; Has no effect on SIP messaging
    
    # Time Zone phone will reside in
    time_zone: EST 
    
    # Phone prompt/password for telnet/console session
    phone_prompt: ""                              ; Telnet/Console Prompt
    phone_password: ""                          ; Telnet/Console Password
    
    # URL for external Phone Services
    services_url: ""
    
    # URL for external Directory location
    directory_url: ""
    
    # URL for branding logo
    logo_url: ""
    
    # SIP Configuration Generic File (stop)
    
    
    Make a file with the above, adjust settings to your situation, name it SIP000000000000.cnf with the 0's being the mac address of the phone. Put it in the tftpboot folder.
  4. vinod New Member

    Hi

    Im using a similar phone configuration file as you've shown to me.

    Everything seems to be fine except the Incoming. Since Incoming is directly going to the voicemail. But the account is registered with the server and shows at the CLI as

    Code:
    Addr->IP     : [I]dsl_public_ip_address[/I] Port 64613
    Defaddr->IP  : 0.0.0.0 Port 5060
    Def. Username: [I]extension[/I]
    Codecs       : 0xc (ulaw|alaw)
    Codec Order  : (ulaw:20,alaw:20)
    Status       : OK (143 ms)
    Useragent    : Cisco-CP7960G/8.0
    Reg. Contact : sip:[I]extension[/I]@[I]dsl_public_ip_address[/I]:5060;transport=udp
    
    I can see that, there is a mismatch in the port used by the phone and the port seen in the Registration Contact.
    Will this create a problem?

    Also I have question with my SIPDefault.cnf.

    Code:
    ; sip default configuration file
    #Image Version
    image_version:P0S3-08-8-00;
    #Proxy server address
    proxy1_address: asteriskipaddress;
    proxy_register: 1;
    nat_enable: 1;
    nat_address: [SIZE=6][COLOR=Red]?[/COLOR][/SIZE]; <---What should i use for this option?
    nat_received_processing: 1;

    Is the server unable to identify the phone local ip address?

    Im getting tired of finding the solution....Please help....

    Many thanks
    Vino
  5. jpe Member

    Ciscos can be an itchbey to setup

    Here is my sipdefault file.
    I have my external IP address in the NAT field.
    The 79xx can be a real pia to get going on SIP, once you do they are rock solid.

    Dumb questions to ask:
    Have you reset the phone by pressing * - 6 - Settings buttons simultaneously?
    Are the NAT settings correct in FreePBX and match the phone?

    (i just checked mine for reference and 2 are set to use NAT, 2 aren't)

    Have you looked at the log files (not cli) to see whats going on?



    Code:
    # Image Version
    image_version: "P0S3-08-6-00"
    
    # Proxy Server
    proxy1_address: "192.168.1.101"
     
    # Proxy Server Port (default - 5060)
    proxy1_port:"5060"
    
    # Emergency Proxy info
    proxy_emergency: "192.168.1.101"
    proxy_emergency_port: "5060"
    
    # Backup Proxy info
    proxy_backup: "192.168.1.101"
    proxy_backup_port: "5060"
     
    # Outbound Proxy info
    outbound_proxy: "192.168.1.101"
    outbound_proxy_port: "5060"
     
    # NAT/Firewall Traversal
    nat_enable: "1"
    nat_address: "your ip address here"
    voip_control_port: "5060"
    start_media_port: "16384"
    end_media_port:  "32766"
    nat_received_processing: "0"
    
    # Proxy Registration (0-disable (default), 1-enable)
    proxy_register: "1"
     
    # Phone Registration Expiration [1-3932100 sec] (Default - 3600)
    timer_register_expires: "3600"
     
    # Codec for media stream (g711ulaw (default), g711alaw, g729)
    preferred_codec: "default"
     
    # TOS bits in media stream [0-5] (Default - 5)
    tos_media: "5"
    
    # Enable VAD (0-disable (default), 1-enable)
    enable_vad: "0"
     
    # Allow for the bridge on a 3way call to join remaining parties upon hangup
    cnf_join_enable: "1"     ; 0-Disabled, 1-Enabled (default)
     
    # Allow Transfer to be completed while target phone is still ringing
    semi_attended_transfer: "1"   ; 0-Disabled, 1-Enabled (default)
     
    # Telnet Level (enable or disable the ability to telnet into this phone 
    telnet_level: "2"      ; 0-Disabled (default), 1-Enabled, 2-Privileged
    
    # Inband DTMF Settings (0-disable, 1-enable (default))
    dtmf_inband: "1"
     
    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt )
    dtmf_outofband: "avt"
     
    # DTMF dB Level Settings (1-6dB down, 2-3db down, 3-nominal (default), 4-3db up, 5-6dB up)
    dtmf_db_level: "3"
     
    # SIP Timers
    timer_t1: "500"                   ; Default 500 msec
    timer_t2: "4000"                  ; Default 4 sec
    sip_retx: "10"                     ; Default 11
    sip_invite_retx: "6"               ; Default 7
    timer_invite_expires: "180"        ; Default 180 sec
     
    # Setting for Message speeddial to UOne box
    messages_uri: "*97"
    
    # t*f*t*p Phone Specific Configuration File Directory
    tftp_cfg_dir: "./"
     
    # Time Server
    sntp_mode: "unicast"
    sntp_server: "192.168.1.101"
    time_zone: "EST"
    dst_offset: "1"
    dst_start_month: "Mar"
    dst_start_day: ""
    dst_start_day_of_week: "Sun"
    dst_start_week_of_month: "2"
    dst_start_time: "02"
    dst_stop_month: "Nov"
    dst_stop_day: ""
    dst_stop_day_of_week: "Sunday"
    dst_stop_week_of_month: "1"
    dst_stop_time: "2"
    dst_auto_adjust: "1"
     
    # Do Not Disturb Control (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    dnd_control: "0"                  ; Default 0 (Do Not Disturb feature is off)
     
    # Caller ID Blocking (0-disabled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    callerid_blocking: "0"            ; Default 0 (Disable sending all calls as anonymous)
     
    # Anonymous Call Blocking (0-disbaled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    anonymous_call_block: "0"         ; Default 0 (Disable blocking of anonymous calls)
     
    # Call Waiting (0-disabled, 1-enabled, 2-disabled with no user control, 3-enabled with no user control)
    call_waiting: "1"                 ; Default 1 (Call Waiting enabled)
    
    # DTMF AVT Payload (Dynamic payload range for AVT tones - 96-127)
    dtmf_avt_payload: "101"           ; Default 100
     
    # XML file that specifies the dialplan desired
    dial_template: "dialplan"
    
    # Network Media Type (auto, full100, full10, half100, half10)
    network_media_type: "auto"
    
    #Autocompletion During Dial (0-off, 1-on [default])
    autocomplete: "1"
    
    #Time Format (0-12hr, 1-24hr [default])
    time_format_24hr: "0"
    
    # URL for external Phone Services
    services_url: "http://192.168.1.101/xmlservices/index.php"
    
    # URL for external Directory location
    directory_url: "http://192.168.1.101/xmlservices/PhoneDirectory.php"
    
    # URL for branding logo
    logo_url: ""
    
    # Remote Party ID
    remote_party_id: 1              ; 0-Disabled (default), 1-Enabled
    
    
    
  6. vinod New Member

    Hi

    I was looking at the Asterisk logs and I got "SIP/2.0 404 Not Found" from my Cisco Phone ip address.

    Detailed log trace:


    Asterisk IP Address: xx.xx.xx.xx
    Cisco Phone IP Address: yy.yy.yy.yy
    Caller Extension: 7223
    Called Extension: 7222

    Code:
    Audio is at xx.xx.xx.xx port 16476 
    Adding codec 0x4 (ulaw) to SDP 
    Adding codec 0x8 (alaw) to SDP 
    Adding non-codec 0x1 (telephone-event) to SDP 
    Reliably Transmitting (NAT) to yy.yy.yy.yy:64613: 
    INVITE sip:7222@yy.yy.yy.yy:5060;transport=udp SIP/2.0 
    Via: SIP/2.0/UDP xx.xx.xx.xx:5060;branch=z9hG4bK02b4a301;rport 
    From: "7223" <sip:7223@xx.xx.xx.xx>;tag=as5b43fe4e 
    To: <sip:7222@yy.yy.yy.yy:5060;transport=udp> 
    Contact: <sip:7223@xx.xx.xx.xx> 
    Call-ID: [EMAIL="720093163cfc9b66737826fc265a77eb@xx.xx.xx.xx"]720093163cfc9b66737826fc265a77eb@xx.xx.xx.xx[/EMAIL] 
    CSeq: 102 INVITE 
    User-Agent: Asterisk PBX 
    Max-Forwards: 70 
    Date: Wed, 18 Mar 2009 11:03:23 GMT 
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY 
    Supported: replaces 
    Content-Type: application/sdp 
    Content-Length: 266 
     
    v=0 
    o=root 4003 4003 IN IP4 xx.xx.xx.xx 
    s=session 
    c=IN IP4 xx.xx.xx.xx 
    t=0 0 
    m=audio 16476 RTP/AVP 0 8 101 
    a=rtpmap:0 PCMU/8000 
    a=rtpmap:8 PCMA/8000 
    a=rtpmap:101 telephone-event/8000 
    a=fmtp:101 0-16 
    a=silenceSupp:off - - - - 
    a=ptime:20 
    a=sendrecv 
     
    --- 
    localhost*CLI> 
    <--- SIP read from yy.yy.yy.yy:64613 ---> 
    [B][COLOR=Red]SIP/2.0 404 Not Found [/COLOR][/B]
    Via: SIP/2.0/UDP xx.xx.xx.xx:5060;branch=z9hG4bK02b4a301;rport 
    From: "7223" <sip:7223@xx.xx.xx.xx>;tag=as5b43fe4e 
    To: <sip:7222@yy.yy.yy.yy:64614;transport=udp> 
    Call-ID: [EMAIL="720093163cfc9b66737826fc265a77eb@xx.xx.xx.xx"]720093163cfc9b66737826fc265a77eb@xx.xx.xx.xx[/EMAIL] 
    CSeq: 102 INVITE 
    Content-Length: 0 
     
     
    <-------------> 
    --- (7 headers 0 lines) --- 
    Transmitting (NAT) to yy.yy.yy.yy:64613: 
    ACK sip:7222@yy.yy.yy.yy:5060;transport=udp SIP/2.0 
    Via: SIP/2.0/UDP xx.xx.xx.xx:5060;branch=z9hG4bK02b4a301;rport 
    From: "7223" <sip:7223@xx.xx.xx.xx>;tag=as5b43fe4e 
    To: <sip:7222@yy.yy.yy.yy:5060;transport=udp> 
    Contact: <sip:7223@xx.xx.xx.xx> 
    Call-ID: [EMAIL="720093163cfc9b66737826fc265a77eb@xx.xx.xx.xx"]720093163cfc9b66737826fc265a77eb@xx.xx.xx.xx[/EMAIL] 
    CSeq: 102 ACK 
    User-Agent: Asterisk PBX 
    Max-Forwards: 70 
    Content-Length: 0
    Also my Asterisk server is on a direct public ip address and on a different location. My Cisco IP phone is with the private ip address on another location. One quick question, does Cisco 7960 IP phones support NAT ? .i.e. to register and make calls with a public server?

    Because my other endpoints like grandstream, snom, etc, are working with the same asterisk server without problem.

    Many Thanks
    Vino
  7. vespaman Guru

    You definitely have this in your SIPDefault.conf ?

    # NAT/Firewall Traversal
    nat_enable: "1"
    nat_address: "Static IP where the phones located"
    voip_control_port: "5060"
    start_media_port: "16384"
    end_media_port: "20000"
    nat_received_processing: "0"
    # Proxy Registration (0-disable (default), 1-enable)
    proxy_register: "1"

    # Phone Registration Expiration [1-3932100 sec] (Default - 3600)
    timer_register_expires: "3600"

    # Codec for media stream (g711ulaw (default), g711alaw, g729)
    preferred_codec: "g711ulaw"

    # TOS bits in media stream [0-5] (Default - 5)
    #tos_media: "5"
    # Inband DTMF Settings (0-disable, 1-enable (default))
    dtmf_inband: "1"

    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt )
    dtmf_outofband: "avt"

    If you have then check both your firewall port forwardings.
  8. vinod New Member

    Did you mean to put the Static IP of my DSL line, where the Cisco Phone sits in?

    Many Thanks
    Vino
  9. jpe Member

    The static ip address where the PBX is residing goes there, not where the phone is.
  10. OTA Guru

    Can you try the phone on the same network as the PBX? Process of elimination. Make sure the phone works on the same network as the PBX first, then worry about bringing it outside that network.

    The Ciscos absolutely support NAT. I've actually had better luck with them than the Grandstreams. I've also never had to put anything in the nat_address line of the Cisco conf file. About half of my extensions are outside of the office LAN, most of them are on dynamic IPs, thus I don't have the luxury of spec'ing out an address. Literally, the nat_address line for my phones is:
    nat_address: ""

    This feels like a firewall issue or a fat-fingered config issue in either the extensions.conf or SIPxxxxxxxx.conf.

    I'm currently staying at a hotel right now, so I have NO control over this network nor their firewall. Sitting at a private address so there's definitely NAT here. No special heroic efforts/config file changes. I've been to a few locations where the phone wasn't able to connect to the t*f*t*p server but still managed to place and receive calls.
  11. jpe Member

    Put it in the peer section

    Code:
    dtmfmode=rfc2833
  12. vinod New Member

    Ok. Now let me check with all kind of possibilities and come back.

    Anyway thanks for everyone's help.


    Vino
  13. vinod New Member

    Im so near to it. Ok, Only might be a few things left to go.

    The phone was once reachable when i modified some value and now it has jumped back.

    To be very clear, let me tell what exactly the problem is.

    My asterisk server is on a Public IP say xx.xx.xx.xx and on a different network.
    My Cisco Phone is on a Private IP say yy.yy.yy.yy and on a different network.
    Cisco phone shows my Broadband Static IP zz.zz.zz.zz on my asterisk server as the register contact.

    Now what are the values should i use for the following?

    nat_enable: ""
    nat_address: ""
    nat_received_processing: ""


    These are the values that confuses me.

    Please help me

    Many Thanks
    Vino


  14. jhamon New Member

    Hi,

    From my own settings I would say

    nat_enable: "1"
    nat_address: "zz.zz.zz.zz"
    nat_received_processing: "1"


  15. vinod New Member

    Solved. Its Working !!!!!!

    There was a mistake in the SIPmacaddress.cnf file and i changed to suit it.

    Im happy now it is working.

    Thank you guys for your immense help.

    Regards
    Vino

Share This Page