1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

SOLVED DPMA Module Alive & Well

Discussion in 'Bug Reporting and Fixes' started by edisoninfo, Sep 11, 2013.

  1. edisoninfo Guru

    I was finally able to get a trace during my Digium D70 bootup where it requests the new firmware and fails. Apache on the piaf box is replying that it is not authorized to access that directory. How do I give it permissions or is it best to move the firmware folder somewhere else?

    Also, the top of the screen keeps saying the firmware module (wrong version, btw) is not available. Where is it getting the version number? There is a newer version in the folder.


    Edit: As soon as I click submit I get a notice that a newer FP module is available. I'm back to where I was with the nicer module.
  2. wardmundy Nerd Uno

    Not sure what the problem is. My install using latest installer worked as advertised without a problem. You probably need to contact Digium for support on this one.
    Code:
    Installing FreePBX 2.11 module for Digium phones...
    --2013-09-11 12:37:52--  http://downloads.asterisk.org/pub/telephony/freepbx/modules/release/2.10/digium_phones-current.tgz
    Resolving downloads.asterisk.org... 76.164.171.238, 2001:470:e0d4::ee
    Connecting to downloads.asterisk.org|76.164.171.238|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 64159 (63K) [application/x-gzip]
    Saving to: “digium_phones-current.tgz”
     
    100%[======================================================================================================>] 64,159      --.-K/s  in 0.1s
     
    2013-09-11 12:37:53 (460 KB/s) - “digium_phones-current.tgz” saved [64159/64159]
     
    digium_phones/
    digium_phones/Services/
    digium_phones/Services/JSON.php
    digium_phones/page.digium_phones.php
    digium_phones/etc/
    digium_phones/etc/res_digium_phone.conf
    digium_phones/functions.inc.php
    digium_phones/module.xml
    digium_phones/images/
    digium_phones/images/resultset_left.png
    digium_phones/images/resultset_first.png
    digium_phones/images/resultset_right.png
    digium_phones/images/resultset_last.png
    digium_phones/views/
    digium_phones/views/digium_phones_general_settings.php
    digium_phones/views/digium_phones_logos.php
    digium_phones/views/digium_phones_phonebooks.php
    digium_phones/views/digium_phones_networks.php
    digium_phones/views/digium_phones_alerts.php
    digium_phones/views/digium_phones_ringtones.php
    digium_phones/views/digium_phones_applications.php
    digium_phones/views/digium_phones_application_queues.php
    digium_phones/views/digium_phones_application_status.php
    digium_phones/views/digium_phones_phones.php
    digium_phones/views/digium_phones_externallines.php
    digium_phones/views/digium_phones_firmware.php
    digium_phones/views/zonelist.html
    digium_phones/views/digium_phones_application_custom.php
    digium_phones/uninstall.php
    digium_phones/install.php
    digium_phones/generate_zonelist.php
    Module digium_phones successfully installed
     
    SETTING FILE PERMISSIONS
    Permissions OK
     
    Please wait...
     
    Successfully reloaded
    Done.
    Now you must register your DPMA key. Follow instructions below.
    --2013-09-11 12:37:59--  http://downloads.digium.com/pub/register/x86-32/register
    Resolving downloads.digium.com... 76.164.171.238, 2001:470:e0d4::ee
    Connecting to downloads.digium.com|76.164.171.238|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1178780 (1.1M)
    Saving to: “register”
     
    100%[======================================================================================================>] 1,178,780  1.87M/s  in 0.6s
     
    2013-09-11 12:38:00 (1.87 MB/s) - “register” saved [1178780/1178780]
     
     
    Digium Product Registration - Version 3.0.5
    Copyright (C) 2004-2007, Digium, Inc.
    Use the '-l' option to see license information for software
    included in this program.
     
    Please select a category
     
    1 - Digium Products
    2 - Cepstral Products
     
    0 - Quit
     
    Your Choice: 1
    You selected 1, Digium Products
    Please select a product
     
    1 - Asterisk Business Edition
    2 - Asterisk Business Edition C Expansion
    3 - Asterisk For Smart Cube
    4 - Asterisk For Smart Cube Expansion
    5 - G.729 Codec
    6 - High Performance Echo Can
    7 - Skype For Asterisk
    8 - Fax for Asterisk
    9 - Free Fax for Asterisk
    10 - Vestec Speech Engine
    11 - Digium Phone Module for Asterisk
     
    0 - Quit
     
    Your Choice: 11
    You selected 11, Digium Phone Module for Asterisk
    Please enter your Key-ID: DPMA-5BR...
    Product available to be registered.
     
    Do you want to register this key now(y/n) y
    DIGIUM END-USER LICENSE AGREEMENT
     
    Do you accept this licensing agreement (y/n)? y
    You will be prompted for the following fields:
        First Name: Last Name: Company: Address 1: Address 2: City: State:
        Postal Code: Country (2-Letter Country Code): Phone:
        Email:
     
    First Name: Ward
    Last Name: Mundy
    ...
     
    Wrote license to /var/lib/asterisk/licenses/DPMA-5BRXXX....lic
    Done.
    Installing res_digium_phone module for Asterisk...
    This is 32-bit CentOS system.
    --2013-09-11 12:39:32--  http://downloads.digium.com/pub/telephony/res_digium_phone/asterisk-11.0/x86-32/res_digium_phone-current-x86_32.tar.gz
    Resolving downloads.digium.com... 76.164.171.238, 2001:470:e0d4::ee
    Connecting to downloads.digium.com|76.164.171.238|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 510771 (499K) [application/x-gzip]
    Saving to: “res_digium_phone-current-x86_32.tar.gz”
     
    100%[======================================================================================================>] 510,771    1.16M/s  in 0.4s
     
    2013-09-11 12:39:32 (1.16 MB/s) - “res_digium_phone-current-x86_32.tar.gz” saved [510771/510771]
     
    res_digium_phone-11.0_1.6.0-x86_32/
    res_digium_phone-11.0_1.6.0-x86_32/res_digium_phone.so
    res_digium_phone-11.0_1.6.0-x86_32/res_digium_phone.conf.sample
    res_digium_phone-11.0_1.6.0-x86_32/README
    res_digium_phone-11.0_1.6.0-x86_32/CHANGES
    res_digium_phone-11.0_1.6.0-x86_32/UPGRADE.txt
    res_digium_phone-11.0_1.6.0-x86_32/LICENSE
    Done.
    You should be good to go now. Loading module...
    Loaded res_digium_phone.so
    OK, Valid product license found
     
    
    Last edited by wardmundy, Sep 11, 2013
  3. wardmundy Nerd Uno

    For the record, here is the FINAL RELEASE of the DPMA installer that I used successfully. Any other versions with any other names will most probably fail as you have described... or worse!

    Thanks to @malcolmd & Co., this one is pretty much bullet-proof...

    Code:
    cd /root
    wget http://incrediblepbx.com/install-digphones.tar.gz
    tar zxvf install-digphones.tar.gz
    ./install-digphones
    
    Last edited by wardmundy, Sep 11, 2013
  4. edisoninfo Guru

    I'm sorry. I guess I didn't explain it well enough. I have all the modules installed on Piaf-Green but am having several issues:

    1. When my D70 boots up it goes to the piaf box for it's configs and firmware. The defaults for the firmware location is <webroot>/admin/modules/digium_phones/firmware_package/.. The phone fails to download the firmware. Doing a tcpdump I can see it issue the http GET command for the particular .eff file but Apache on the PiaF box replies that it is not authorized to access that folder. Hence the phone fails to boot since it can not get passed that firmware download point.


    Additional issues with the DPMA module.....

    2. The DPMA module upgraded itself to 2.11.0.2 from Schmooze. The install script you mention installs the original 2.10.xxxx script which after a few minutes updates to the 2.11.0.2. When the module is in the Easy mode, I can go to the normal FreePBX extensions menu and click on any extension, then click submit and it will create all of the existing extensions in the DPMA module. Even phones that are not Digium phones. I can then go into the DPMA menu and delete out the non-Digium phones. That works. I then click Edit on the D70 and make changes to it's config. Clicking submit refreshes the screen but non of the changes are saved. They all revert to whatever was created by the "Easy" mode creation process.

    3. I tried deleting the one remaining extension, switched to Easy mode disabled, then click add extension. I filled in all the settings and clicked submit. Again, the screen refreshes but nothing is saved. I can not add extensions except to switch to easy mode and back.
  5. wardmundy Nerd Uno

    Hmmm. So the DPMA code installs fine. It just doesn't work. That is most definitely an issue for Digium to resolve. They provide free support for their phones so I would definitely use it.
  6. tm1000 Schmoozecom INC/FreePBX

    @wardmundy It's now in the online repository and Schmoozecom maintains the module. No need to download from Digium's website. Just FYI

    Simply run:
    Code:
    amportal a ma upgrade digium_phones
    Last edited by tm1000, Sep 12, 2013
  7. tm1000 Schmoozecom INC/FreePBX

    It's in module admin. I am not sure how you would know. Other than the fact that when the module has been installed in FreePBX it will check for updates through module admin anyways so I am confused as to why this is a big deal? Digium never supplied a script to download the module and install it so they gave it to us and now we put it in the online repo so people don't have to download an external script to manage this module. Should be a win-win? That's my thinking at least.

    Last edited by tm1000, Sep 12, 2013
  8. wardmundy Nerd Uno

    The script has been updated to install the latest Schmooze release. :dots:
    Last edited by wardmundy, Sep 13, 2013
  9. wardmundy Nerd Uno

    @edisoninfo: The reported bug hopefully will be addressed in an update later this week.
    Last edited by wardmundy, Sep 13, 2013
  10. Just wondering out loud if anyone create a ticket on this? I don't see one at issues.freepbx.org , forums are nice for communication, but if we can let's try open up tickets in the shiny new jira ticketing system, this should help keep everyone on the same page as far as the status of problems and resolutions. (if there already is a ticket and I'm missing it please post a link.)
  11. wardmundy Nerd Uno

    Tony is aware of it. I spoke with him last night.

  12. :beatdeadhorse5:Yep, I know everyone is aware of it, and I have been monitoring various threads for a few days myself, but it would be great to see bug tickets on this stuff, instead of looking at post from here or the FreePBX.org forums, Asterisk Forums etc. we have one location to give "official" status updates.

    Bugs, already known or not should be reported at issues.freepbx.org so our bug marshall can escalate issues like this when needed, and resolutions can be addressed to the entire community, (there is also a voting tool on the new jira ticketing system, which would allow people to vote on issues and features, giving the development team an idea of what is important to the community.)

    FreePBX is a community based project, and we need help when issues arise and often the best way to do that is to officially document them using the tools already in place.
    wardmundy likes this.
  13. billsimon Guru

    @reconwireless what do we need to do to submit issues? I can't log in to the tracker. I requested a password reset, got the e-mail, reset my password, and now am told:

    You do not have a permission to log in. If you think this is incorrect, please contact your JIRA administrators.
  14. Once you sign up at freepbx.org for an account, it takes 30 minutes or so to sync with jira, you should be good now.
  15. billsimon Guru

    I'm in now. Thanks.
  16. The ticket for this issue has been closed, and the update pushed in module admin version 2.11.0.3 of the Digium Phone Module, http://issues.freepbx.org/browse/FREEPBX-6747

    Please report any additional issues or bugs at issues.freepbx.org

Share This Page