1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Help with Cisco 7912G

Discussion in 'Endpoints' started by jerm, Dec 1, 2007.

  1. jerm New Member

    Hope there's someone who can give me some direction.

    Two weeks ago I was sitting at my computer at the butt crack of the night and was looking into this whole VoIP thing and what it had to offer when I stumbled upon this site announcing PBX in a flash, which had been posted not 30 mins prior. I must have been one of the first to download. I've never used Asterisk before, but I've been reading and learning a lot in these last two weeks.

    I went wild on eBay and have a truck load of Cisco 7912G phones, a server to take over the world, a few PoE switches, etc. etc. I got over excited. :eek:

    So I set up a basic system, got some extensions going, a few DIDs, a private number in Long Beach, CA, you name it. It's great!

    The one thing I'm trying to do is I have a guy that lives out in bum f- nowhere and I figured why not give him a Cisco 7912G, have him plug it into his DSL and give him an extension and we have a nice little external "internal" system. I pick up the phone and dial extension 206 and presto! Give him a DID, whatever I want. Only problem is that I have waded through forum after forum, document after document and have not been able to find an exact way to make this work. I have found things that gave me a general idea, and I've been experimenting for a good two days now but haven't been able to make it work. The closest I got was dialing from my side and it rings on the other end and gives me a fast busy signal at the same time and that's about it.

    If anyone could give me any sort of direction on this, I would very much appreciate it. Tks.

    Jer
  2. jroper Guru

    Hi

    Congratulations on progress so far.

    So the first thing you need to check is whether the DID is arriving at your box.

    Open up an Asterisk CLI -(asterisk -rvvvv) then dial the inbound number, and see if anything happens.

    If nothing appears to happen, go to General Settings in FreePBX and check that you have "Allow Anonymous Inbound SIP Calls" checked.

    Try again.

    If nothing happens, then check you have the SIP ports forwarded to * on your router (5000 - 5082UDP and 10,000 to 20,000UDP), and the NAT entries described in the install document (extenip/externhost and localnet). If you are getting calls in and out of your remote extension, you can be fairly sure this is all working as it should.

    Then go to your DID provider, and check that the number is being forwarded to the right place, and in the right format - if you have a choice - and assuming they deliver the call via SIP and not IAX.

    Repeat as necessary until stuff happens on your asterisk CLI wen you dial the number.

    When stuff does happen, you should see, amongst everything else, the DID number that is delivered as well as the CLI, (the number you called from)

    Copy the DID as delivered by your service provider EXACTLY as delivered:-

    Now you have 2 options as to what to do next.

    1. You can put the number exactly as delivered, into inbound routes, and direct it to a destination.

    2 You can put the number (exactly as delivered) in the direct DID entry against the extension. If you do this, delete the number from Inbound Routes.


    Then you should be working.

    Joe
  3. jerm New Member

    Thanks so far

    Dear Joe,

    Great reply, learnt a lot from it already. However, your reply doesn't seem to address my problem to begin with, as (now that I re-read my post), I didn't make it clear what I was trying to achieve.

    It's not that a DID call doesn't arrive to this remote extension. It's that this remote extension doesn't even talk to my free PBX over the Internet.

    It's a Cisco 7912 series IP phone; a SIP phone. That phone is behind a DSL modem with dynamic public IP address, and a Linksys 8-port wired router. I'm trying to make it talk to my Free PBX which is behind a DSL modem/router with static public IP address from Verizon.

    So you have two sites to work with: one with the PBX which is behind a static IP addressed DSL, and the SIP phone from Cisco, which is behind a dynamic IP addressed DSL.

    On the PBX side, I'd set the router to port-forward ports 5060 UDP/TCP, 16348-32768TCP, 4569UDP, and 5004UDP all to the pbx.

    On the phone side, I'm only playing around with the SIP settings on the phone, but only on a trial+error basis, as I'm not really sure which setting means what. Here are the things I can set for SIP configuration:

    1. SIP Proxy: I'd set this one to be the static public IP address of the other side, where the pbx sits.
    2. User ID: I gave it the extension number I set up in the pbx.
    3. Password: I gave it the password I set up in the PBX.
    4. Use login (Yes/No): I'm not sure what to do here... The phones that are sitting on the pbx-side in-house network and working fine, have it on NO.
    5. Login ID: I assume if I were to set the prior option to YES, I would have to enter here some ID, maybe the extension number.
    6. Local SIP port: by default, it's 5060, and I don't think I need to change that.
    7. Local RTP port: By default, it's 16384, and I don't think I need to change that.
    8. Backup proxy timeout: I don't know what to do with this; by default, it's 0.
    9. Outbound proxy: Well, here I tried a lot of things: leave it blank, set it to the public IP address of either side, etc. but didn't make any difference.
    10. Register expires: 3600 (default) and I don't think I need to change that.
    11. Register with proxy (YES/NO): I tried both, but didn't work. Not sure what should it be.
    12. NAT WAN IP Address: I tried to leave it blank, and also tried to put in the public IP address of both sides, but no success.

    I'm not sure... I might have port-forwarding issues on either side, or SIP setting issues on the Cisco phone... I just don't know exactly which setting means what.

    If you know the answer, don't hesitate:) I'm here
    Thanks
  4. jerm New Member

    Another thing is port-forwarding setup in the router that I'm not sure about:
    When you want to enter a port range, it's giving you "Global port start"-"Global port end" and "Local port".
    So I can enter a range of 10000-20000 to forward to the PBX, but the way the router shows after saving the setting is:
    Global start: 10000
    Global end: 20000
    Local port: 10000
    To me it means that any traffic coming in, using a port in the range of 10000 - 20000 will all be forwarded to the pbx as 10000, so, as an example, even a packet with port 15000 will arrive to the switch as port 10000. Am I right with this concern? If yes, how do I fix it?
  5. Titanous New Member

    What router do you have?
    Is 16384 and 5060 UDP forwarded to the phone?
    Register with proxy should be yes.
    Try setting the NAT WAN address to the phone side's public IP.
  6. jroper Guru

    Hi

    I'm not familiar with kind of phone, but general principles apply. but with NAT on both sides, it's not easy.

    On the PBX you need in sip_custom.conf: -

    externip = 1.2.3.4 ; where 1.2.3.4 is your public IP address.
    localnet = 192.168.1.0/255.255.255.0 ; where 192.168.1 are the first 3 octets of your IP address.

    Check the extension on the PBX, and ensure that that nat=yes

    reload asterisk at this point.

    Next, On your firewall, at the PBX end forward port 5000 -> 5082 UDP and 10000 -> 20000 UDP to the PBX.

    On the phone - put in exactly the same settings as you would for your local phones, as we know they work, with the exception of the location of the PBX, which clearly needs to be your public IP address.

    Next, you need to edit the firewall settings at the phone end.

    The lazy way of doing it is to put the phone on the DMZ. Once you have done this and confirmed it is working, do exactly the same port forwarding for the phone as you have for the PBX.

    Hopefully, it will now work.

    Joe
  7. jerm New Member

    Got something going: I went to a different remote site with this cisco phone, where we have much less security, and much less firewalling going on. The phone finally connected to the pbx. I was able to make an outgoing, outside call to my cell-phone, but with only one-way audio:eek:utgoing to my cell-phone. Anything I said on my cell-phone didn't make it back to the phone:(.
    Now: I called voicemail (a call that doesn't leave the pbx, but has to travel between the pbx's site and the remote cisco phone's site, over the public Internet). Only once could I establish 2-way audio, end even then, the sound of the voiceprompt coming from the pbx's voicemail faded away to nothing after about a minute.

    I tried another thing: calling an extension that's at the same site where the pbx is. Since I'm alone on this project, I had nobody to answer, but at least I heard ring-back tone (something that I haven't heard when I called my cell-phone). After about 20 seconds of ringing-no-answer, I was forwarded to the voicemail, and the greeting didn't fade away.
    During all my testings, on one occasion, I was also able to establish 2-way audio to my cell-phone, but got very delayed and garbled audio back from the cell-phone.
    So that's where I stand now. Again, I played around for about 2 hours, changing settings on the phone, the routers on both ends, even made some changes on the sip.conf file but again, these were trial and error, and didn't get me anywhere. In doing some google-ing on the subject, I find that NAT can get nasty on SIP and I'm hoping that somebody here has a quicker answer than me spending another couple of days on it.
    Thanks.
  8. jerm New Member

    Figured it out! Someone's dang firewall setting...:D Thanks kcallis for your phone call and help!
  9. w1ve Guru

    Jerm,

    I am in the same boat -- fairly new to Asterisk and PBIAF, but an experienced s/w engineer and VOIP person...

    I have been given a CISCO 7921G Wireless VOIP phone... And I'd like to get SCCP going... Have you had any luck?

Share This Page