1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

Install PIAF from USB Flash Drive

Discussion in 'Add-On Install Instructions' started by bmore, Dec 15, 2010.

  1. Mashman New Member

    Thanks for Sharing all that work! I have been strugling with the piaf installation on my new acer veriton for a week now! I'm realy suprised how we still depend on harcheic optical drives...

    I have folowed your direction last night and it worked like a charm! But even though it was late and I was getting tired, I'm pretty sure I never got prompted for anything like root password and keyboard language... Is it only me? So this morning I'm left with what appear as a succesful installation but I dont know the root password.

    Thanks!
  2. wardmundy Nerd Uno

    Is there a particular brand of USB flash drives that works well with unetbootin? All of our 8GB Kingston DataTraveler drives crash Windows 7 and Windows XP almost instantly when unetbootin begins. :crazy:
  3. Mashman New Member

    I had no problem with a 16Gb Corsair GT and a 4Gb Kingston 102.
  4. Mashman New Member

    I have rebooted on the USB stick I had created yesterday and I confirm that First, I dont get the initial piaf red warning installation screen and second, i'm never prompted for any input... It goes directly in formating of the drive and the centos installation!

    What am I doing wrong?:confused5:

    Btw: man the installation goes fast on a high speed USB stick!
  5. wardmundy Nerd Uno

    If you see no prompts, try root - passworm to get in. That is enabled for visually-impaired users that skip the standard install steps.
  6. Mashman New Member

    Thanks for the input Ward!

    I will try that as soon as my piaf scripting magic is completed.
  7. Mashman New Member

    Bingo! You had it right Ward! I'm in now!

    Just for reference, as you can see from my posts, the installation took roughly 1 hour on my Acer Veriton VN282G-ED525L. Not bad! I just need finish the pbx configuration now.

    Thanks!
  8. bmore Guru

    Improved process

    I have improved the process. You will no longer need the Centos dvd. This means that this can be done on a usb drive with about 700 MB free. I will write it up a little later. I also need to upload some modified ks*.cfg for Ward and a modified syslinux.cfg. These *.cfg will need to be copied to the root (/) of the usb drive. and Ward will also host the ks*.cfg files.

    Thanks for trying this Mashman. The new syslinux.cfg will restore the initial Piaf warning screen. I will also have a script in a day or 2 that will automate the creation the bootable install flash drive.

    After I upload the new scripts I would appreciate any feedback, and let me know if it does not work for you so I can fix any bugs. Thanks
  9. bmore Guru

    Please see the new procedure in the first message. I have also uploaded new files. Please let me know if you experience any issues and if it works for you. I need to know if works on system configurations different from mine.
  10. bmore Guru

    Ward,

    I am becoming better at Linux :wink5: and so I now have a better understanding of the boot process. I have revised the procedure to essentially just use the piaf iso with a couple additions. A new ks.zip is attached to the first post. Please update the hosted files with these.

    To make the process easier you could create an ISO for USB flash drive install, it is only 13 MB larger than the standard.

    The following are the requirements:
    1. Edit a 1.7.5.5.5 piaf ISO: Delete the folders:
      Code:
      docs, images, pbx, repodata, source
    2. Copy the unmodified piaf 1.7.5.5.5 iso to the Centos folder in this new iso
    3. Copy the *.cfg files in the ks.zip file to the root.
    4. Save the iso and you are done.

    The new iso has 2 folders (isolinux and CentOS). The isolinux folder is the original; CentOS has the 1.7.5.5.5 iso. Root has the original files (updated k*.cfg) plus an added syslinux.cfg.

    This iso can be used to create the flash drive with Unetbootin, no additional mods needed. Just boot it.

    By the way this procedure can be used to install from any hard drive (requires at least 2 drives in the system)... though unless you are an advanced user you really do NOT want to do that... Stick to using a flash drive.
  11. Mashman New Member

    Bmore, I have followed you latest instruction and I am now getting the piaf installation splash screen (wich for some reason identify itself has being version 1.7.5.5.4) and being prompted for password timezone and keyboard.

    The CentOS installation was pretty smooth and I am now at the piaf flavor installation stage. So I assume that everything will be perfect!

    I wanted to test the 64bit version, but it seems to be available only with the previous piaf release (1.7.5.5.4) at this time.

    Thanks again for the good work! Many people and certainly I apreciate moving away from CDs...
  12. bmore Guru

    Mashman. Thanks for testing and providing feedback.

    Bobby
  13. wardmundy Nerd Uno


    Oh my. Isn't this nice! I'm uploading a new, E-X-P-E-R-I-M-E-N-T-A-L 1.7.5.5.5 Flash-Drive-Only ISO to SourceForge which has everything already in place as you have outlined above. Please let us know if it works since I've never gotten unetbootin to do anything other than crash our one and only Windows machine. The ISO should be available for downloading in about an hour.
  14. bmore Guru

    You do know UNetbootin is available for Linux too?

    At the top of the UNetbootin home page (Download for Linux) or direct Link. It can also be installed directly from some package managers like the one in Ubuntu. Applications>Ubuntu Software Center... Then search for Unetbootin.
  15. rossiv Guru

    BMore and Ward:
    I just used this on an EEEBox and it is fantabulous! :D This will make my life so much easier.

    And to Ward, I successfully ran UNetBootin on a Windows 7 Business 32-bit laptop to burn the flash drive - Uggh..no UNBI for Mac :(
  16. wardmundy Nerd Uno

    Type of flash drives that work without a problem would be helpful. With Win7, the Kingston DataTraveler seems to choke on the syslinux.cfg copy. Once it is manually copied over (I put it everywhere), the flash drive works just fine as well. What file location is necessary for syslinux.cfg? Just the root folder??
  17. bmore Guru

    Yes, syslinux.cfg goes to the root folder. I use the flash drive with Ubuntu or Win 7 Ultimate.. not really sure what my drive is... Some generic one I got with software I bought.
  18. bmore Guru

    Great to know that it worked. Thanks for trying it, we need feedback to see if there are any issues.
  19. wardmundy Nerd Uno

  20. ou812 Guru

    Almost but no cigar

    I created 2 usb drives 1 8gig Patriot and 1 8gig Kingston data travler,
    I used windows XPpro win no problems from unetbootin and PIAF1755-usbonly iso which created all the files but ALL .cfg and syslinux were empty. I down loaded the ks.zip file from first post on forum and copyed to usb.
    I installed on a test box and every thing went well up till system reboot time. Now when booting from hard drive the screen just shows GRUB and goes no further. I have used both usb sticks and have the same results. could it be the .cfg and syslinux files I used.

    Gary

Share This Page