1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

FYI Install PIAF on CentOS Existing Installation

Discussion in 'Add-On Install Instructions' started by jroper, Jul 6, 2010.

  1. pok New Member

    hey never mind it was their ajax console that was screwing it up... i just ssh with putty and it works.. great stuff!
  2. DragonHawk Guru

    Good to see it is working. Here are a few other tips if anyone else has some problems:

    - Aside from packages that already exists and no hardware clock, you shouldn't be getting any errors. If you get problems, please capture your putty logs so we can look into where the error is (you did remember to set your scrollback to greater than 200 lines and enable session logging, right?)


    - My experience has been that piafdl hangs in 2 cases:
    1. There is a dependency that is missing.
    2. piafdl is unable to contact the pbxinaflash servers.
    Make sure your server has proper DNS servers setup in its' network config (this could also cause errors during the prep script too). If all else fails, add the Google DNS servers as your first two (8.8.8.8 and 8.8.4.4).


    - If you still can't get PiaF to install, try a different data center. Sometimes IP blocks get accidentally blacklisted by the PiaF web servers and this has caused me trouble in the past.


    - As pok discovered, don't use the web based consoles, always use Putty or another SSH client. Aside from problems with copying and pasting commands into the web console, they also generally have no scrollback and logging capabilities. When you setup your Putty connection, make sure you increase the scrollback higher than the default 200 lines and also enable logging so you have a record of any errors that may come up.
  3. pok New Member

    ok installation just finished.. during the installation it stalled at one point and said "failed to download fopfix29.tgz.. WRITE THIS DOWN.. Press ENTER to continue' .. after that it installed the rest of it fine... when it rebooted..
    Asterisk = OFFLINE
    IPTABLES and IP6TABLES = OFFLINE..
    WLAN0 = OFFLINE
    other non-important stuff:
    Hidd, Samba,Bluetooth OFFLINE

    Running Asterisk Version = UNKNOWN
    ZAP/DAHDI = UNKNOWN

    are these things all normal? would I need to manually install that fopfix29 patch? thanks
  4. DragonHawk Guru


    The install failed. Check your DNS servers and try again. I'm not sure about 32 bit, but on 64 bit Asterisk is finicky and needs to be re-compiled every time there are fixes added to it. It's possible that with FOPFix missing the asterisk compile failed?

    For good measure, you may want to start from scratch again (re-provision your VPS) and use Putty so you can enable the logging option on your connection while you do the install. If you get errors during the VPS script, let me know so I can look into the cause.
  5. pok New Member

    here is my current DNS and HOSTS info.. my VPS IP is 66.228.93.133.. would i need to add this IP into the HOSTS like: 66.228.93.133 localhost? what do I check with my DNS? I knew this was harder than I thought..
    DNS:
    [root@li289-133 ~]# cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search members.linode.com
    nameserver 207.192.69.5
    nameserver 97.107.133.4
    nameserver 207.192.69.4

    Hosts:

    [root@li289-133 ~]# nano /etc/hosts
    GNU nano 1.3.12 File: /etc/hosts

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
  6. pok New Member

    here is a little bit at the end of the 2nd try that concerns me

    STARTING ASTERISK
    /var/lib/asterisk/bin/freepbx_engine: line 152: /usr/sbin/safe_asterisk: No such file or

    directory
    safe_asterisk: no process killed
    mpg123: no process killed

    -----------------------------------------------------
    Asterisk could not start!
    Use 'tail /var/log/asterisk/full' to find out why.
    -----------------------------------------------------
  7. wardmundy Nerd Uno

    Looks like Asterisk didn't compile. This could be because of an inability to download the software (DNS or network problem) or an inability to compile the software (usually because of inaccurate time on your host).
  8. pok New Member

    yes it looks like asterisk is not there at all with all this missing paths/files.. i'm not sure about inability to download, it downloaded and installed everything else fine.. On my second try i added following line in the /etc/hosts
    <my external ip> localhost localdomain.localhost pbx.local pbx

    i am doing this directly from memory so maybe reversed a couple of them.. during the time i added, i checked they were the correct syntax.. I can access everything else in the PIAF main screen except for freepbx...
  9. pok New Member

    sorry for being a noob but how can i check if the DNS is configured and working correctly on the vps? thx
  10. wardmundy Nerd Uno

    The major reason we provide a turnkey ISO install is to avoid many of these types of problems. Others may have some ideas but we really, really don't support homegrown installs of PBX in a Flash. We don't discourage it. We just don't have the staffing levels to debug all the potential problems which easily number in the thousands.
  11. pok New Member

    totally understood... installed with ease on my virtualbox at home.. didnt expect it to be so different.. ah well... what can i do..
  12. sircolin Guru

    @DragonHawk
    If you are committed to getting this script working on proxmox/openvz i would be happy to assign you a openvz vps machine for 2 weeks to help you get this done, I should really take a more active role but I'm just so busy right now and have no time to sit down and write another script. or help debug yours, it would be nice to have a up to date openvz template again.

    Col
  13. DragonHawk Guru

    I just threw together an old P4 with 1.7GB of ram in it to create a OpenVZ server for testing. It can't do x86_64, but I'm checking the 32 bit version for any problems.


  14. DragonHawk Guru

    These customized installs can be a little tricky sometimes. Ward is completely correct that they can't support them and as much as possible Joe and I try to support our own scripts here in the forums.

    If you want a PiaF VPS fast and easy, you can always go with Host Virtual. They have a PiaF image ready for deployment. They also support IPv6 which is an added benefit if you wanted to get into that as well. In addition, I know that the script does work on VPS.net's CentOS 5.4 x86_64 image as I did much of my testing on that image in the SLC D cloud (I did have problems with CHI C though as that IP range was blacklisted by pbxinaflash.net's security - if you have problems with downloading after running piafdl it can be the cause).

    If you feel like increasing your linux knowledge by working through with the install script and working out the problems you are experiencing, then please let us know of any workarounds you had to do in order to get it to work. If it is a LinNode specific issue, we can document it, if it is a bug with the script then we can fix it.



  15. DragonHawk Guru

    The issue Pok is experiencing is due to Linode using a custom kernel. Because downloading and compiling custom kernel headers is beyond the scope of this script, I have added a check for Linode kernels to the script. If anyone comes across other VPS suppliers that use custom kernels (not the base kernels or the Xen kernels), please let me know so I can add a check for them.

  16. DragonHawk Guru

    From researching the changes required on an OpenVZ system to get this working, and because there are OpenVZ images available for PiaF, I'm not going to support OpenVZ for this script.

    I have added a check for OpenVZ and Proxmox kernels to the script to prevent wasting a users time and bandwidth.

    The updated script will be available later tonight - I am also updating a few of the packages in it.



    EDIT - Script version 2.00.1 is now uploaded to the ActiveSpeak site. Please let me know of any errors you come across.



  17. johnnypuffs New Member

    Hello - Just wanted to give a quick thanks to Joe for writing this script and to DragonHawk for his tweaked version..

    I used DragonHawk's script to install on a 64bit XenServer 5.6 Guest and it worked flawlessly! I then used the incrediblepbx18-vm.x script to install Incredible PBX and again it went off perfectly.

    Zero problems on the install and so far with testing everything seems to be working perfectly!

    Thanks for the work guys!
    JP
  18. DragonHawk Guru

    You're welcome. Thanks for letting us know it worked for you!
  19. DragonHawk Guru

    New Website

    I have added installation instructions for the script on the ActiveSpeak website for anyone needing more detailed directions.
  20. MACscr Member

    Is this activespeak script still the best way to install Piaf on an existing server? I am wanting to make sure I install an LTS version too.

Share This Page