1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

Munin Install Now Fails

Discussion in 'Bug Reporting and Fixes' started by boynas, Aug 18, 2009.

  1. boynas Member

    I have tried to install munin several times using the "install-munin" script.. and it doesn't work.

    The log says that it has installed everything, but in the www/html/maint/munin/ folder, there is no index.htm or php file only a style.css and a folder called cgi/

    Any ideas? munin service is working, and munin.conf at /etc/munin/ points to the right folders.

    Really, really... is there a problem? is always the same since a couple of months ago.

    thanks!
  2. darmock PIAF Developer

    Interesting. I believe that munin has been updated at the repository level and some things have changed. Will look into it.


    Tom
  3. dodgly New Member

    Double-check that path. I noticed in my /etc/munin/munin.conf a problem on line 7. I confirmed the munin html path to /var/www/html/maint/munin and updated the config file.

    As I recall the default munin.conf had either html or maint missing from the path.

    Hope that helps.

    --Lyle
  4. MyKroFt Guru

    ya the install-munin does not work anymore, verified on 3 different boxes :(
  5. MyKroFt Guru

    ya, correcting the path in /etc/munin/munin.conf started generating the html files
  6. boynas Member

    verify that the path was wrong

    I've verified the file /etc/munin/munin.conf and "html" was missing

    I changed it to:

    /var/www/html/maint/munin

    I restarted munin by:

    service munin-node restart and I can't still see anything in:

    http://ip-address/maint/munin

    I don't know if I need to restart something else, and I can't restart the box right now.

    It might just need some time to gather info so I am going to wait.

    There is no index file or anything in the "/var/www/html/maint/munin" folder.

    Thanks for your help.
  7. boynas Member

    Confirmed it WORKS!!

    It works and is so cool that I didn't have to wait a long time. I have stats from the day that I first installed it. (obviously because the nodes where gathering info.

    Question though. I can't see any SIP related graphics. Like "sip channels/codecs" or "sip registered peers"

    Any ideas

    I can see the sip related plugins in the /etc/munin/plugins/ directory but I don't see anything that I could change.
  8. dolesec New Member

    the install is hosing the munin.conf

    mine had the this for the html directory ...
    htmldir /var/www/maint/maint/munin


    changed to ....
    /var/www/html/maint/munin

    all was well after that

Share This Page