1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Nortel IP 1535 $27.95

Discussion in 'Endpoints' started by w1ve, Sep 29, 2010.

  1. tm1000 Schmoozecom INC/FreePBX

    This makes me want to program a 'provisoner' on these phones that could use a simple installed t*f*t*p client to look for the files it needs and then upload and replace.

    That would be wonderful........
  2. fang0654 Guru

    Should be pretty easy to do - the config files seem to be pretty straight forward.

    The only pain part is you still need to go through the network setup first, and then enable the ftp server. That leaves no chance for full automation. Still would be awesome though :)
  3. tm1000 Schmoozecom INC/FreePBX

    Considering it runs a modified version of linux I'm sure I could write something in the init scripts to use t*f*t*p to look for files, then you wouldn't have any need for ftp.

    This is my thought process. I still need to look into the linux part of this phone (as it sits on my desk, I need to get working on it)

    Edit: wanted to mention, I would have to 'modify' the firmware to upload said t*f*t*p-client, then enable it. etc...so yes you are in fact correct as you'd still have to enable ftp! argh!
  4. blakekrone Guru

    What I'm looking at doing is trying to see if it is possible to basically create a DynDNS type service running on the phone, most of these phones go out to family members and if Comcast were to change my IP ever I don't want to have to go and touch the phone. If I had a script running on the phone that checks to see what the IP is for my PBX I could then re-write the cfg file with the new IP.

    Now that we have shell access there is a ton of opportunity with these phones.
  5. fang0654 Guru

    You may not need to - one of the phones I have boots up looking for a t*f*t*p server to download 'config options'. I haven't figured out how to enable/disable that yet, or exactly how the configs are supposed to be formatted, but there is hope! :) At the very least we may be able to tweak what it looks for.
  6. blakekrone Guru

    I think we can automate the initial provisioning server process as well. The phones are sending an Option 43 request to your DHCP server. These are typically answered by certain vendor class identifiers to return IP addresses and such. If we can figure out the format for the FTP address then we should be good for an initial provisioning.
  7. fang0654 Guru

    Can also reconfirm that it is originally an LVP-1800. It is in a few comments in a bunch of the config files. Along with a lot of debug code commented out in the startup scripts.
  8. fang0654 Guru

    Another interesting thing on this phone (forgive me if this is common knowledge and I am completely ignorant), it seems that the phone jack in the back of the phone may be used as a modem. There are modem drivers being loaded, and ppp tools on the phone.

    Looking deeper at it, it looks like it is actually meant to call another phone and set up a phone to phone video call. Maybe something they were working on and never finished? All the stuff is in:

    /usr/etc/ppp

    It looks like what they used for an original product demo. All the code is there to dial another phone, establish a connection, and start a video call.
  9. vanDivX Guru

    Intercom does work!

    WOW after posting in the morning about intercom not working, I thought I should try if it really doesn't work but then I went to work...

    back home now I remembered and I tried it and bingo, intercom just works!! :eek: :rolleyes5: :smile5: :biggrin5:

    I always used 'server side' intercom with Aastra phones - there is setting in their web interface where you choose server of phone side but for these Nortel phones it just means making sure you got intercom enabled in the Feature Codes section in FPBX - I use custom *7 prefix + extension number for placing intercom call (only use if your extension numbers do not start with 7xx plus check if you use some feature codes that start with the same code *7)

    The default prefix for intercom is *80 - try it, works with hands free too, just press the green button and dial *80ext# and be amazed as I was :crazy:
  10. Check out /usr/local/lgvp/config.cfg

  11. blakekrone Guru

    After more digging around if you look at what they did over at SipX for the phone we should be able to hopefully translate some of that to these. If you watch the phone they will in fact try to get a common config from t*f*t*p first if it receives Option 66 with an IP. If that fails it tries via FTP.

    http://track.sipfoundry.org/browse/XX-1714

    The common file is named 1535.cfg and is in the hardware version root folder. When I tried to enable it my phone hung on loading until I hit the end button.

    A good boot log is /var/log/mmi.log

    An interesting find with the SipX docs is that you can use a FQDN it appears in the config files. This would be huge for those of us that have Dynamic IPs. I'm not sure if all of the variable names are 100% correct, again, I just took SipX velocity macros and converted it to a straight clear text files for us.

    Attached Files:

  12. vanDivX Guru

    Read my post above, I just tried before reading your post and found to my surprise that it works. That's skepticism for you ;)

    Also the 'beep' is there when intercom call comes in, maybe increase the sound level by pressing 'up' on the four way toggle while you are on intercom call (on the receiving end where beep should be heard). For some phones sound level is being adjusted only for the function of the phone you are just using, like Aastras that you say you have are like that.

    As for the # sending the intercom call along which doesn't work - I found its best to get into the habit of pressing the green button to dial, even if you are off hook when dialing, it works to send the call - intercom or normal along.
    For making on hook call, its not necessary to first press the green button, just dial your number and press it when done. I like that because I always felt telling your family members to press the # if they don't want to wait four seconds was kinda geeky for them, this is much better. Maybe it works the same way on Aastra phones too (using the hands -free button to send dialed number along).

    The phone seems to be set to cut the sound level to zero when not registering any talking, then when you suddenly say something and you are not too loud the phone doesn't seem to pick it up right away, not sure what that function is called... maybe its asterisk that does it if set to 'pass silence' along when people don't talk during call to save bandwidth? Its usually felt most on hands free calls when you are farther away from the phone.
  13. Sacrilego Member

    Prices gone up!

    The prices have gone up again, they want 77 for them now.
    They rejected my $61 bid so I called them up.

    I could not get them go any lower than 69 for 5 phones.

    Oh well, I guess the fun is over for me.
    At least I got 4 for 50 each before the prices went up.
  14. warraich Member

    I guess we should stop buying so the price will come down.
  15. rxcomm Guru

    A couple of things

    1) Regarding the 0.2.89 fw - after taking a look, it appears that this really is a newer fw version than the 0.2.76, so there isn't any reason to try to put 0.2.76 on the phone if you have this fw already. I had originally thought it may be just a hack to include the Turkish language on an earlier fw version. But the fact that the /usr/local/bin/version file references the CS2K system indicates that is not the case. CS2K was not included until fw 0.2.71 or so.

    2) I took a stab at writing a web provisioning interface for these phones. Since the phones do not have a web server on them, the route I took was to download some of the config files via ftp, edit them, and put the edited versions back on the phone. This provisioning interface has been tested on exactly one phone (mine), but if you would like to give it a try, you can find php code and instructions below. As always, proceed with caution and at your own risk.

    Dave

    HTML:
    cd /var/www/html
    wget http://pbxinaflash.net/source/nortel1535/nortel1535.tar.gz
    tar zxvf nortel1535.tar.gz
    rm nortel1535.tar.gz
    
  16. wardmundy Nerd Uno

    On the FTP download attempt (on a Turkey special), I get:

  17. fang0654 Guru

    Factory reset

    Anyone know of any way to do a factory reset if we happen to hose something? A "Press and hold these two buttons while powering up to go into recovery mode" or something like that? I would love to really tinker with these things, but I don't want to brick anything.
  18. vanDivX Guru

    I tried (phone was English as shipped, HW 1.0, Firmware 0.2.50) and got told

    Pressing the button 'Update Config Files' then returned (BTW on another phone which has FTP disabled you don't see this button, that's how you can tell if its enabled or not - that's clue for others)

    But of course this later result was to be expected.
    Why would FTP fail?
    I have PIAF Gold running in VMWare, the phone is on LAN with the PC that is running the PIAF VMWare. I get the same result in IE or Firefox, the PC runs win7 if that has got anything to do with it. The phone has FTP/Telnet Enabled in its setting, I am able to telnet in with putty. Also used WINSCP to copy your folder to var/www/html
  19. rxcomm Guru

    Oops...

    I forgot one key step :biggrin5:.

    chown and chgrp the /var/www/html/nortel1535 directory to asterisk. Then your http server will have write permission in that directory.

    Dave

Share This Page