1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

Not receiving calls - Phone Number not in service

Discussion in 'Help' started by tdnnash25, May 4, 2009.

  1. tdnnash25 New Member

    I have another thread open that is addressing this, but the thread Title was actually for something else. So, sorry if you are reading this here and there....

    When I dial my DID, I see the call traffic in /var/log/asterisk/full, but I'm receiving a "The number you have dialed is not in service. Please check the number and dial again". This happens when the destination of my incoming route is set to my extension and when it is set to my WebMeetMe. So, I'm not really sure if it has anything to do with my incoming route settings. I'm really stumped on this. My gut says either my trunk settings are wrong somehow or there is a dial plan config goof up ... even though I haven't messed with the dial plans. I'll admit though, I'm pretty much a newbie so maybe it has nothing to do with either.

    Help?
  2. MGD4me Guru

    If you are sure the DID call is being delivered to your PBX (as shown in the logs), then the call is not being processed as you would expect.

    You can temporarily go to the General Settings page and "allow anonymous SIP calls" (or, something like that) and try the call again. If the call now magically 'works', then you do not have an Inbound Route properly configured for this DID, or you forgot to configure one. Review your settings, and go from there.
  3. tdnnash25 New Member

    Anonymous SIP Calls

    I set "allow anonymous SIP calls" to true and I do now get calls. When I uncheck it, I get the Phone not in service error message. I can't seem to figure out where I'm going wrong. I don't want to allow anonymous calls, but my incoming route looks like it is configured correctly. I've set the DID to my account number with my voip provider. I've also set it as the actual DID. Something weird has to be going on with the incoming route but I'm not sure what it is. I'll keep digging, but if anyone has any tips that'd be great.
  4. jeffmac Guru

    According to your other thread you are getting the following when the call comes in:
    [2009-05-02 20:58:46] VERBOSE[7158] logger.c: -- Executing [5557029890@from-sip-external:1] NoOp("SIP/5557029890-09835ba0", "Received incoming SIP connection from unknown peer to 5557029890") in new stack

    Based on this entry you need a DID defined for 5557029890.

    Now if you "munged" this up to obscure the number then you need to define a route for the DID that was there before you obscured it.

    Now - as to why this is an "unknown peer" to start with..... You previously said you were registered and could make outgoing calls. Are the calls coming in from the IP address that you are registered to? Some providers don't send calls to you from the same IP address that they have you register to. I believe that to be "known" peer you have to be "registered" with them.

    To check registrations - go to the FreePBX "Tools" tab, and select the "Asterisk Info" option, and then "Registries".

    Jeff
  5. tdnnash25 New Member

    Thanks, checking now.
  6. tdnnash25 New Member

    According to "Registries" I am registered to my voip provider. I see in my logs that the IP address my calls are coming from is not the IP address that I'm registered to. What now? Talk to my voip provider?
  7. tdnnash25 New Member

    Is it bad to allow anonymous sip calls?

    This got me thinking. Is it bad to allow anonymous sip calls? It seems the only way to get calls to come in and go where I want, I have to check this.
  8. MGD4me Guru

    No, no need. The reason you need to register with your provider is so that they know WHERE to send your DID calls to, since you are on a dynamic IP address. If you had a static IP address they would permanently record that address in your account, and all calls would be forwarded there, without the need to register.

    Since you ARE receiving calls, as shown in your log, you ARE registered. And you can see in the logs that your call are hitting the "from-sip-external" context, which is a 'catch-all' context to trap anonymous incoming calls.

    What does your register string look like? Does it have an account or DID number at the end, like:

    username:userpass@voip-provider.com/DID-number ???

    In your Trunk configuration, have you a 'context=from-trunk' statement?
  9. tdnnash25 New Member

    Static IP / Registering with VSP

    I have a static IP address. My registration string is like this: userpass@voipprovider.com/accountnumber

    Should I let them know I have a static IP?
  10. MGD4me Guru

    I think this thread is either the same, or is related to, your other thread on "DID routing - How does it work?" Let's keep only the one discussion going, it's a pain flipping back and forth.

    Your 'other' thread indicates ypou are using Voipvoip.com as a service provider, right? If so, they have a configuration guide for trixbox, which also uses FreePBX to configure Trunks and Outbound Routes, so these setting would also pertain to PiaF. However, since you will likely only be using the ulaw codec, all others can be deleted. Therefore in your Trunk configuration, start off with:

    disallow=all
    allow=ulaw

    These two statements should be at the very top of the list.

    Second, they show the register string as:

    REGISTRATION STRING

    5551231234:XXXXXXXX@sip3.voipvoip.com/55551231234 <<< you have something totally different !
    (for 5551231234 use your VoIP VoIP account and for XXXXXXXX use your password)

    Problems? Please check our installation troubleshooter.
    NOTE: VoIPVoIP does not provide technical support for Trixbox.

    Rather than fumbling around, go to the Voipvoip website and follow their trixbox config, and try to follow those instructions first, then we can do further trouble-shooting later. Until we know exactly how you have everything set up, it will be a guess, at best.

    See: http://www.voipvoip.com/trixbox/
  11. tdnnash25 New Member

    Sorry about the duplicate thread. The other started off asking one thing then got tied into this - hence why I opened this one.

    Anyways, I followed the trixbox configuration guide. The only way that I can have my incoming calls go where I want is to allow anonymous SIP calls. Isn't this bad?
  12. MGD4me Guru

    From the 'old' thread...

    Despite the fact that you've purchased a DID from Voipvoip.com (I believe they call it a Virtual number?), when someone calls your DID it arrives at your PBX with your ACCOUNT number, instead of whatever your actual DID number is (from the log, above):

    "DID=5557029890"

    Therefore, you want to use your ACCOUNT number as the DID entry in your Inbound Route. In your Trunk, try two different ways in configuring your Register string. Try both.

    First (default): 5557029890:yourpassword@sip3.voipvoip.com/5557029890

    Alternate: 5557029890:yourpassword@sip3.voipvoip.com
  13. tdnnash25 New Member

    Your suggestions still aren't working. But, thanks for your help.

    I'm not quite sure you got what I meant. The only way that the calls that come from VoipVoip.com (yes, they do call DID's virtual numbers) to my server get sent to my extensions(s) if if I have "allow anonymous calls" checked under General Settings. The Registration string doesn't make a difference (tried both methods that you suggested). In fact, I tried configuring my trunk to allow the IP address that the calls are coming from and it still didn't work. (host=IPThatI'mRegisteredWith&IPThatCallsAreComingFrom).

    I opened up a ticket with VoipVoip.com about this and they said it is a known thing with FreePBX that incoming calls don't work right without enabling anonymous calls. Is that true? I'm trying to figure out what is so bad about anonymous calls anyway.
  14. MGD4me Guru

    Errr.. Yes I did get what you meant. If you read back a bit you'll see that I was the one who detected that the incoming calls where in fact being delivered to your PBX, but were not finding a matching Inbound route, so ended up in the anonymous category. I suggested you to "temporarily" allow these calls in to see whether the call would eventually ring through. Whether leaving this setting 'open' permanently would do any harm, I cannot say, as I have absolutely no knowledge as to how secure your system is.

    That aside, you didn't confirm how your Inbound route is configured.

  15. tdnnash25 New Member

    Sorry, my inbound route is using my voipvoip account # instead of my DID. This is the only way it will work. I then have the destination set my extension. Hopefully someone can tell me if allowing anonymous calls is bad.
  16. jroper Guru

  17. blanchae Guru

    This might be a simple solution, you can add an inbound DID # to any SIP extension through "FreePBX - Extension - <extension #>" <- (that's the extension you want to associate with the DID). Give it a "DID name" plus the "DID number", and it will create the inbound DID rule when applied. Works great. When a DID comes in matching the inbound DID, it sends it to the SIP extension.

    The error message is because the dialed in SIP extension "5557029890" doesn't match any of the PBX's extension.
  18. ohmram New Member

    thank. it work for me now

Share This Page