1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Check out the 6 new Certified Incredible PBX Builds for Asterisk 11 and 13 featuring CentOS 6, Ubuntu 14, Raspberry Pi 2, and Asterisk-NOW.
    Dismiss Notice

"not writable" message on DAHDI config page

Discussion in 'Help' started by luckman212, Jan 11, 2011.

  1. luckman212

    luckman212 Guru

    Hi guys. hoping someone can shed some light on this. I searched everywhere I could but came up empty on this--
    how can I fix this? or does it even need fixin' ?


    PiaF purple, ast 182-rc1, latest fpbx modules installed...
  2. randy7376

    randy7376 Guru

    Verify /var/www/html/admin/modules/dahdiconfig/etc/chan_dadhi.conf has the following permissions and ownership:

    I was able to replicate by setting this one file to read-only.

    EDIT: At least check it, but that doesn't seem to be the issue.
  3. randy7376

    randy7376 Guru

    When I changed the permissions back after I posted the above message, I still had the "not writable" error. :banghead:

    A little digging in /var/log/httpd/error_log turned up this little gem that stood out (there were several errors!):

    Let's see what's on or around line 1233 in functions.inc.php:

             * Write Modprobe
             * Write all the modprob options to modprobe.conf
        public function write_modprobe() {
                   [COLOR=Red] $file = "/etc/modprobe.d/dahdi.conf";
    [/COLOR] [COLOR=Red]                 if ( ! is_writable($file)) {
                            echo "not writable";[/COLOR]
                    $fh = fopen($file, 'w');
                    fwrite($fh, "#******************************************#\n");
                    fwrite($fh, "#* Auto-generated by FreePBX, do not edit *#\n");
                    fwrite($fh, "#******************************************#\n");
    It's trying to write to a file it has no access to - /etc/modprobe.d/dahdi.conf. The file exists, but is owned by user root and group root.

    I've modified the permissions, as shown here...

    That should take care of it. I no longer have the "not writable" error.

    This doesn't appear to hurt anything on my system as the file contains nothing more than the "Auto-generated by FreePBX" message above. YMMV...
  4. luckman212

    luckman212 Guru

    Thanks Randy, I did as you described but afterwards my DAHDI page got completely hosed (not sure why, resulted in a white frame w/ lots of php errors on it). What I ended up doing was "force install" the DAHDI Config module again via the Module Admin page. This got everything more or less back to normal again.
  5. randy7376

    randy7376 Guru

    That's kind of weird... as long as you didn't try to modify any of the PHP code (there would be no reason to), it should have worked. I'm glad reloading the module worked out for you.
  6. luckman212

    luckman212 Guru

    Yep, I think something got hosed by the Sangoma wanpipe driver install (for the UT5x) which seems to be a bit crufty and in need of some dusting off...

Share This Page