1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Check out the 6 new Certified Incredible PBX Builds for Asterisk 11 and 13 featuring CentOS 6, Ubuntu 14, Raspberry Pi 2, and Asterisk-NOW.
    Dismiss Notice

PIAF2: /var/log/messages missing

Discussion in 'Bug Reporting and Fixes' started by jucha, Dec 27, 2011.

  1. jucha

    jucha New Member

    File /var/log/messages does not exists in centos 6.1 and 6.2.
    I ran an phpagi, and i can not to see errors like oracle conection.
    I create manual the file, but nothing.

    cron, maillog, spoller does not exists, yet.
  2. randy7376

    randy7376 Guru

    I just did an install about an hour ago and /var/log/messages exists for me along with the others you mentioned.

    What do you get if you run:
    rpm -qa | grep -i syslog
    It should return rsyslog-4.6.2-12.el6.i686 which I believe is the package name for syslog in CentOS. If it's missing, you can try to install via yum:

    yum -y install rsyslog
    I would suggest that if you find other problems, you might want to consider a re-install.
  3. darmock

    darmock PIAF Developer

    There are any number of changes

    start here


    The list of changes is vast. We have tried to take into account these changes however we can't make it just like it was in Centos 5.x. So people have to adapt and overcome. For example cron is different as is init.

  4. jucha

    jucha New Member

    Hi, I have PIAF 2061 64Bits

    root@piaf1:/etc/asterisk $ rpm -qa | grep -i syslog
    root@piaf1:/etc/asterisk $

    root@piaf1:/etc/asterisk $ yum -y install rsyslog
    Transaction Check Error:
    file /etc/logrotate.d/syslog from install of rsyslog-4.6.2-12.el6.x86_64 conflicts with file from package syslog-ng-3.2.5-1.el6.x86_64
  5. randy7376

    randy7376 Guru

    You already have syslog installed. Hence, the conflict.
  6. jucha

    jucha New Member

Share This Page