1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Remote aastra unregistering ?

Discussion in 'Endpoints' started by Speedy2k, Feb 15, 2010.

  1. Speedy2k New Member

    I have a Remote 57i phone that is unregistering alot, i don't know why! here is what i got in the log file!
    It does that in loop all the time??
    Does someone have any idea why this is happening ?
  2. kenn10 Guru

    OK. You've got it set to re-register every two minutes (120 seconds) and it seems to be doing that. Not sure you need it to do the qaulify=yes since at most, if it does not re-register within two minutes, Asterisk will know it is down. I generally set my remotes for register=3600.

    As to the qualification portion, I don't understand what is happening with how often qualify is running.

    Does the phone actually un-register at the far end? Have you tried setting qualify=no and seeing what it does?
  3. Speedy2k New Member

    Yes and it does nothing, it seems that asterisk is waiting for a registration every 120 seconds, i have set the register in the aastra to 60 seconds and it seems to keep the phone to unregister.
  4. kenn10 Guru

    Then I suspect the answer lies in one of the sip*.conf files in /etc/asterisk. I'm running FreePBX 2.7 which has further subdivided the sip.conf files but you should look for your maxexpiry, minexpiry and defaultexpiry and lines in whichever file they live in on your system.

    Here are some settings from my file:
    Code:
    alwaysauthreject=yes
    jbenable=no
    rtptimeout=30
    maxexpiry=3600
    allowguest=yes
    defaultexpiry=120
    minexpiry=60
    srvlookup=no
    registerattempts=0
    registertimeout=20
    notifyhold=no
    g726nonstandard=no
    t38pt_udptl=yes
    videosupport=yes
    maxcallbitrate=768
    canreinvite=update
    rtpholdtimeout=300
    rtpkeepalive=0
    checkmwi=2
    notifyringing=yes
    
  5. Speedy2k New Member

    i got the min max and default expiry set as your file. but it seems to be a remote firewall issue, since i got another remote extension with the exact same config file and it is working just perfect, is there any setting into a firewall we should adjust to let the aastra phone send is registration as it should be ?
  6. jmullinix Guru

    I have noticed this issue with remote Aastra phones only. I shorten the registration period for the phone on both FreePBX and on the phone. Also, make sure the port is set to 5060. That field is blank by default, I believe.

    I don't have this problem on remote Snom phones, by the way.
  7. mag Guru

    I've also seen the same issues with remote Aastra phones and discovered it had to do with the firewall used.
    Can't remember the exact solution, but I may have had to disable some firewall "feature" to allow gaming or voip calls.

    I suspect it has something to do with a NAT timeout somewhere.
  8. Linetux Guru

    This is, most likely, a firewall problem.

    I have an application that has remote Aastra's in many other people's networks - ones I don't have control over. I've had to work with a number of the less-experienced IT staff in order to educate them on how to work their firewall to allow for the phones to stay online.

    I too am having difficultly in remembering the exact setting - it's always a little different if it's a Checkpoint, or Watchdog, or SonicWall.... whatever the case might be.

    FWIW, ASA's don't seem to have this problem.

    One other cause can be latency causing the phone to lose its registration, but that doesn't seem to be the case for you.

    FYI, one other issue I've seen with another less-popular firewall was the blocking of the UDP ACK's during a SIP call. The symptoms are the call dropping after about 30 secs - basically the firewall was blocking the ACK when Asterisk was sending "200 OK" to the device - and since the ACK was blocked, it wasn't getting back to Asterisk - which in turn destroyed the call because it didn't think the endpoint was online anymore.
  9. kenn10 Guru

    UDP Port

    The prior comment just jogged my memory. You need to make sure that if your Aastra phones are using UDP port 3000 that the firewal will accept UDP 3000. My 9133i phones need that port open on the firewall.
  10. carlosmp New Member

    Firewall UDP Settings

    Check your firewall at both ends. Many firewall will close UDP tunnels after 30 seconds of no activity. If you have your phone set to register every 120, it will by default try every 60.

    NOtice that your logs have 64 second gap between reachable and unreachable.

    I've got many Aastras for clients outside the main location and don't have these issues once the firewalls are set to have UDP timeouts over 120 to allow the phone to register.
  11. talltrees New Member

    Solution - ….

    I had this issue, with a server behind NAT and the remote phone behind another NAT.
    Also call quality broke up badly, I traced it to a bug in the current 57i / 6757i firmware…
    I have reported this bug to Aastra who were unaware of it but are now working on it.
    This does not affect any other Aastra phone as far as I can tell.
    The solution….
    Roll back to Firmware version 2.3.1.26
    Which will work on the latest 6757i as I have rolled back new phones to this old firmware to avoid this issue.
    I hope that helps, let me know if that sorts it out, I am certain it will.
  12. talltrees New Member

    I had this issue, with a server behind NAT and the remote phone behind another NAT.
    Also call quality broke up badly, I traced it to a bug in the current 57i / 6757i firmware…
    I have reported this bug to Aastra who were unaware of it but are now working on it.
    This does not affect any other Aastra phone as far as I can tell.
    The solution….
    Roll back to Firmware version 2.3.1.26
    Which will work on the latest 6757i as I have rolled back new phones to this old firmware to avoid this issue.
    I hope that helps, let me know if that sorts it out, I am certain it will.

Share This Page