1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

TeleYapper PhoneBook v5.01 - BETA

Discussion in 'Add-On Install Instructions' started by The Deacon, Oct 28, 2010.

  1. The Deacon Guru

    I don't know about you, but I'm *LOVING* the new TeleYapper v5.0 that Ward just published!

    Since Ward did all the heavy lifting on TeleYapper, I figured it was only fair that I do my part and update the TeleYapper PhoneBook (TYPB) to work with the latest (and in my opinion, GREATEST) version of TeleYapper yet!

    There are a couple of changes to TYPB that you should know about:
    • This version ONLY works with version 5.0; so if you're using TeleYapper 4.0, DON'T INSTALL THIS VERSION because it won't work and it will break stuff.
    • Since TeleYapper 5.0 uses two fields (providers and locations) I created two separate tables in the reminders database (called, oddly enough, providers and locations). These two tables *MUST* have at least one entry each added for TYPB to work correctly. They can be dummy entries, but they must be entries nonetheless. (I could have added them for you, but how much fun would that have been?!?)
    • This version also adds an icon to the administration screen. Not sure if I like that or not, but it's been requested several times.

    The installation is pretty straight-forward...

    Code:
    cd /root
    wget http://www.highness.org/typhonebook_v5.pbx
    chmod +x typhonebook_v5.pbx
    ./typhonebook_v5.pbx
    Once the module is installed, do the following:

    1. Point your browser at your PiaF box and log in as "maint".
    2. Select "Module Admin", then select "TeleYapper Phonebook" (its in the Maintenance section) and select "Install"
    3. Once the configuration has been reloaded, you can click on the "Tools" tab and then select the TeleYapper Phonebook button.
    4. You will need to initially add at *LEAST* one "Provider". So select "Add a provider" and enter their name (and select submit).
    5. You will need to initially add at *LEAST* one "Location". So select "Add a location" and enter the location name (and select submit).
    6. You are now free to Add / Edit / Delete entries to your TeleYapper phonebook.

    Remember - this version is still beta and will probably have a bug or six. Please report any funkiness and I'll do my best to make it better.
  2. rossiv Guru

    I just installed it and this is exactly what I have been looking for since 5.0 came out! Awesome! If I find bugs, I will let you know, but right now, it is working fine on a 1.7.5.5.2 GOLD install.
    Thanks!
  3. What happened to highness.org

    I would like to try this out, but the site appears down....

    Any one got a local copy ?
  4. The Deacon Guru

    I am in the process of moving and took the site down yesterday afternoon, but should have it back up later this afternoon.
  5. TheShniz Guru

  6. The Deacon Guru

    The web site is back up and things should be back to normal again.

    -Rick
  7. wardmundy Nerd Uno

    Tried it this morning and the site was down again. Here's a link on our source mirror site. Thanks!!!
  8. ou812 Guru

    When I try to install it fails and gives this message.

    root@pbx:~ $ chmod +x typhonebook_v501.tgz
    root@pbx:~ $ ./typhonebook_v501.tgz
    -bash: ./typhonebook_v501.tgz: cannot execute binary file

    Gary.

    Attached Files:

  9. mainenotarynet Not really a Guru - Just a long time user

    Look at Post # 1 again -- it is not a .tgz it is a .pbx

    and .tgz need to be unzipped first anyways.
  10. The Deacon Guru

    OK - looks like the web server still isn't working. Comcast is for some crazy reason, blocking port 80 inbound to me for the time being... It's a known problem, and they've got their best people working on it. :crazy:

    So, what you will need to install this locally are these two files (I've attached them here). Copy both files to the /tmp directory and run the following commands:

    Code:
    cd /tmp
    mv typhonebook_v5.pbx.txt typhonebook_v5.pbx
    chmod +x typhonebook_v5.pbx
    ./typhonebook_v5.pbx

    That should do the trick. If not, please let me know.

    Attached Files:

  11. rossiv Guru

    Just installed the TYPB on a 17553(4?) Purple install, and I tried to insert a new entry, but I got this:
    Code:
    
        QUERY = INSERT into reminders VALUES (0, '', 'Exec Meeting 4 1 11',  'Ross Lindsay', '03/31/11', '2330', 'Chadwell's Room 305 at WHS',  'Please have your bunny money with you.', '201', '8434469999', 0, 0)
    INSERT failed.
    
    Everything is standard - no DB passwords changed or anything. I can add/delete providers/locations, but it still doesn't work.
    --Edit
    It must be midnight. It doesn't like punctuation, or at least apostrophes. NM.




  12. This addon brooke my piaf GUI's could you please verify that ... ??

    Thanks in advance.
  13. rossiv Guru

    Reason is probably that the download link for the fax icon is dead in this script.
  14. well i fixed the problem changing the owner and the rights of the directory ......
  15. maliron New Member

    Still messed up for me...

    I just installed TYP and I too am having the same issue where my main menu now looks terrible. I changed the owner of the folder to asterisk, but it did not seem to make a difference for me.

    Any suggestions?

    Also, I need some advice on if I am barking up the right tree in going the teleyapper route here.

    I have a customer who wants to be able to have my system call a dictation service and read the progress notes for a patient into it.

    The reasons are convoluted of course. He has a thick accent do the dictation system has a hard time with his voice, and that is the only method the hospital will accept. He has trained Dragon on his Mac to understand him, which will then generate the text. He then wants my system (or any other solution) to read that Dragon generated text in a plain as day US accent to the hospital's dictation system.

    Teleyapper is the only way I could think to implement this, and I have never used it before, and am only just not getting started with Asterisk.
  16. rossiv Guru

    Don't really need Teleyapper. Could modify NV Reminders to do it.
    Anyway - try redownloading the Kennonoft UI. Lemme find the instructions and I will post them here.

Share This Page