1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

vitelity DIDs losing registration

Discussion in 'Trunks' started by rolfbeethoven, Mar 7, 2009.

  1. rolfbeethoven New Member

    I have two DIDs from vitelity through the PIAF link and unfortunately the trunks are losing their registration and the good folks at Vitelity have told me that it is my fault. I don't have a static IP and so they are telling me they can't help me. When I reboot my system, the DIDs work fine for a day or so and then I start getting failed call notifications. I have not made changes to my system and I'm using NAT=yes. My ports are forwarded as suggested in the PIAF install instructions. I can make calls out just fine and I can receive calls in for a few days usually without a problem. Even when the VOIP DID lines don't work, my PSTN line still works through the same PIAF server.

    I've search around for ways to troubleshoot the problem but I haven't been able to find a solution that seemed to fit my problem. I would appreciate some pointers.

    1) Is there a way to locate the source of the problem? (Could it be my set-up? My router? My DSL connection? Vitelity?)
    2) Is there a way to check for the registration being lost and have my PIAF box re-register successfully? Right now I have to "amportal restart" to get the lines back. Is there a better way to reregister?

    Thanks,
    Tyler
  2. jmullinix Guru

    Tyler,

    What type of router/firewall are you using. If you use a PFSense firewall, I have seen this behaviour if the outbound NAT is not set to static on the firewall.
  3. ronw Guru

    If you are using a router with a DSL modem, make sure the modem is in bridge mode. I average 1 failed registration attempt per day to Vitelity. It never fails on the second attempt.

    ronw
  4. rolfbeethoven New Member

    John, I'm using a Linksys wrt54g. It is using the original Linksys firmware.

    ronw, I double checked the modem and I am in bridge mode. How are you registering to Vitelity? Are you manually running a command or is Asterisk registering when it hits a checkpoint?

    Is this a common problem that I'm experiencing? This is one case where I absolutely do not want to be special.

    Thanks.
  5. cjkeeme Guru

    It's possibly a router issue. Try finding a router you can flash with OpenWRT or Tomato. Pfsense is also a great bet. I have Vitelity and have no problems.
  6. ronw Guru

    Tyler,

    Below is the registration string for the inbound trunk in FreePBX.
    useraccount:password@inbound18.vitelity.net:5060

    Also the PEER Details;
    username=useraccount
    type=friend
    secret=password
    qualify=no
    nat=yes
    insecure=very
    host=inbound18.vitelity.net
    disallow=all
    context=from-trunk-sip-vitel-2inbound
    allow=ulaw

    Vitelity has two servers that do not work for everyone. They are at ip addresses 64.2.142.86 and 64.2.142.105.

    Currently, inbound18.vitelity.net resolves to ip 64.2.142.116 and works for me.

    I am using a wrt54gl router with stock firmware and do not have any ports forwarded.

    ronw
  7. rolfbeethoven New Member

    Thanks for the responses. I had to take a few days off from poking around the system and I haven't had any dropped registrations over that time period. I'll keep searching for the cause, but hopefully it is something that was fixed on the Vitelity side.

    I did add a script that checks the registration status of the trunk every hour and 1) emails me if it is unregistered and 2) does a sip reload if it is unregistered. Since I haven't had any dropped trunks, it hasn't been tested. Will a sip reload normally fix a dropped trunk issue or do I have to do an "amportal restart", which has always worked in the past. I just found the sip reload the other day and decided to try it. Basically I just want to force a registration.

    Thanks as always.
  8. ronw Guru

    Performing a sip reload will trigger a re-registration.

    Good luck.
    ronw
  9. rolfbeethoven New Member

    This is really frustrating. I tried the trunk config that you posted and it worked for a few minutes and then stopped working.

    I check sip show registry and the trunk shows as registered. I call the VOIP DID 10 times in a row and I get through 50% of the time. I'm not changing anything on my system. I call 10 times right after another. Sometimes it works. Sometimes it doesn't. If I wait a minute and try another 10 times, I won't get through at all. Wait another minute and call and I get through 10 times in a row.

    I have a Linksys wireless G router and flashed it with the dd-wrt software, but that hasn't helped hold the trunk registration. Infact I think the registration is even flakier now.

    I'm toying with the idea of running my server in the DMZ. I put it in the DMZ to test and the calls went through every time. I figure that as long as I have fail2ban running and have strong passwords that I should be safe. Is running Asterisk in the DMZ a really bad idea?

    Also, is it possible that my setup will never work (bad karma between the server, router, Vitelity?) or is it that I'm got a bad config somewhere that I just need to resolve? I would appreciate some sage advice so I know if it is worth continuing this effort to get a DID to be available on a reliable basis.

    Thanks.
  10. OTA Guru

    What is the DHCP lease time provided by your ISP and how often are they actually changing your IP? Does Vitelity support IAX? If so use that instead of SIP. IAX seems to handle NAT/DHCP far better than SIP.
  11. dghundt Guru

    At least for outbound, vitelity iax2 was frequently losing registration for me on multiple boxes over the years. I simple reload always fixed it. So, I always had to go back to sip. Your mileage may vary.
  12. rolfbeethoven New Member

    Lease time is not an issue. IP changes but not frequently.
  13. rolfbeethoven New Member

    ronw,
    how is the call getting through your router if you have no ports forwarded?
    thx.
  14. ronw Guru

    You only need ports forwarded if you have remote extensions or allow anonymous incoming sip requests. The registration string identifies Vitelity's server address, so the sip request is not anonymous.

    What inbound server are you registering to? I use inbound18@vitelity.net.

    Be sure and set qualify=no on the inbound trunk. When set to yes, you will loose registration if there is delay in getting a response from the server.
  15. dghundt Guru

    I bet that is the problem for me. I'll give it a try.
  16. rolfbeethoven New Member

    Here's my trunk setup in FreePBX. Can I choose which of the inbound servers I want to use? I'm using a different one than you.

    type=friend
    username=myusername
    secret=mysecret
    context=from-trunk
    insecure=very
    host=inbound7.vitelity.net
    disallow=all
    allow=ulaw
    nat=yes
    qualify=no

    I thought that I had to forward ports to get SIP to work through my NAT. Ward's HOW TO (and every other how to I've seen) recommends forwarding ports for sip and rtp. What am I missing?
  17. ronw Guru

    Your trunk setup looks good. I would think that you will have to use the server assigned by Vitelity. I tried using inbound7.vitelity.net. My trunk will register, but incoming calls do not make it to my pbx.

    Do you also have a Register String that looks like this:
    myusername:mypassword@inbound7.vitelity.net:5060
    ?
  18. kenn10 Guru

    You must use the inbound server assigned to you by Vitelity. Your numbers will not ring to you (even if you are registered to another server) if you don't use the correct assignment from Vitelity. Trust me, I've tried it!
  19. rolfbeethoven New Member

    Yes. My Registration String looks like that. (obviously with my username and pswd). The funny thing is that the calls go through one minute and don't go through the next.

    I even opened an account with global synapse and moved all the trunks over. I just did this last night and I'm still checking if everything is correct, but I'm getting the same issues. Calls go through one minute and don't go through the next. (I deleted the same trunk in my home pbx and did amportal restart on both machines.)
  20. jmullinix Guru

    This still sounds like a router issue to me.

Share This Page