1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

Voicemail, codecs and recording distortion

Discussion in 'Help' started by kevsworld, Feb 10, 2011.

  1. kevsworld New Member

    System specs:
    PIAF=1.7.5.5
    Asterisk=1.6.2.15
    FreePBX=2.7.0.6

    Currently remote Yealink handsets but they are on a private WAN, so only routers no NAT etc. The trunks are SIP trunks - no ZAP or onboard trunk cards.

    I have 2 questions.

    1. I currently have the voicemail codec set to record the messages in wav (slin) (not WAV gsm) The problem I have is that when listening to voicemail messages, the message is distorted. Its hard to describe without hearing it but its a bit like if you record something and the input is too loud, you loose some of the sound though clipping. But actually the message is quiet volume wise in comparison to the built in prompts which are crystal clear by the way. It is an even distortion across the whole message, so I dont think it is caused by lost packets or jitter. I am using a jitter buffer on the sip channels but I have tried turning these off and still experience the same issue. I am transcoding (see below) but even if I turn this off ie. set the format to ulaw and allow the phone to use ulaw) I still have the same issue.


    2. What codecs can be used for voicemail? The phones are using (and can only use) the G726-32, since I believe this is the only version asterisk supports ie. not the 16, 24 or 40 versions). I can not use g711 as I have limited bandwidth. So, I tried setting the voicemail.conf format=g726|wav which didnt work (only the wav file is created) , so I tried format=g726-32|wav which does work - the recorded file is created but when I try to play it back the system tries to play a file with the .g276 extension and not the .g726-32 which is actually there.
    For example:
    message001.g726-32 is created in /var/spool/asterisk/voicemail/ but when you try to play your message from the phone, the system looks for message001.g726 and of course just don't play the message. Not sure if this is a bug or if it just isn't supported.

    Any light on this would be great. I am at a bit of a loss on what to try next.:confused5:

    Kevin
  2. kevsworld New Member

    to clarify

    Well i have done a bit more investigation with this. If I leave voicemail messages from one extension to another, then the distortion problem doesn't occur. So it appears to be a problem with the SIP trunks. They are actually from another TDM PBX with a VoIP card installed. Weird thing that I can't figure out is why only the voicemail messages are affected. You can have 2 way conversations over the same SIP trunks without any issues, however, every single voicemail that any callers leaves suffers from this issue. Must be something different in how the system handles a two normal conversation call and a one way voicemail recording.
    If I actually run a Wireshark trace, is there anyway to put the RTP packets together from that and hear the actual wav file?? Also, no one got any suggestions about G726 codecs and recording messages using this format directly?

    Kevin
  3. tm1000 Schmoozecom INC/FreePBX

Share This Page