1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

ZAP setup help Wildcard TDM410P

Discussion in 'Help' started by v0ip-Pete, Jul 18, 2008.

  1. v0ip-Pete New Member

    Hi,

    I have a Wildcard TDM410P, 2 FXO (red) modules installed.
    I am trying to dial out over PSTN.

    Latest version of pbxiaf, zap, etc (update-sources, scripts, fixes)

    Card is detected, the following in /var/log/messages


    Zapata Telephony Interface Registered on major 196
    Zaptel Version: 1.4.11
    Zaptel Echo Canceller: MG2
    ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 16 (level, low) -> IRQ 177
    Port 1: Installed -- AUTO FXO (FCC mode)
    Port 2: Installed -- AUTO FXO (FCC mode)
    Port 3: Not installed
    Port 4: Not installed
    VPM100: Not Present
    Found a Wildcard TDM: Wildcard TDM410P (4 modules)

    Card shows up in zttool

    However it won't show the card in asterisk CLI

    pbx*CLI> zap show channels
    Chan Extension Context Language MOH Interpret
    pseudo from-zaptel en default

    also:

    root@pbx:~ $ zaptel_hardware
    pci:0000:02:04.0 wctdm24xxp+ d161:8005 Wildcard TDM410P

    pbx*CLI> zap show status
    Description Alarms IRQ bpviol CRC4
    Wildcard TDM410P Board 1 OK 1 0 0


    What have I done wrong (or not done)??

    Thanks
  2. v0ip-Pete New Member

    Got it!

    There was no include /etc/asterisk/zapata-channels.conf in my config file.

    I now get

    pbx*CLI> zap show channels
    Chan Extension Context Language MOH Interpret
    pseudo default en default
    1 from-pstn en default
    2 from-pstn en default

    I cannot dial out, I get the following:

    -- Executing [s@macro-dialout-trunk:20] Dial("SIP/2003-09cceb68", "ZAP/1/xxxxxxxxxxx|300|") in new stack
    -- Called 1/xxxxxxxxxxxxxx
    -- Zap/1-1 answered SIP/2003-09cceb68

    What else have I missed?
  3. jroper Guru

    It looks like its getting to your ZAP card, I'd check the physical connections to the card.

    Joe
  4. mkhurrum New Member

    I am facing the same issue - the physical connection is fine, I checked. I am also hitting a brick wall trying to debug this - Incoming is working fine - little low on gain, but I can play with that latter - need to get outbound working.

    MK
  5. mkhurrum New Member

    Need help with FXO - outbound calling

    Guys,
    if i reinstall old releases, they work fine. This issue is with new zaptel or some update. Is there a way to install like 1.0 or 1.1 of the PBXIAF?
  6. darmock PIAF Developer

    You want help and you don't tell us the specifics of the install. Post the output from the status command. That should tell us something. Then you realize that the current version of freepbx handles zap call a little different right? You have it set up in both trunks and Zap Channel DID's right? How are you referring to the channels in trunks by group G0 or did you split them? how did you enter the include for zapta-channels?

    Should be

    #include zapata-channels.conf

    Have you modified the /etc/sysconfig/zaptel file yet to comment out everything except the card you are using?

    Once you have ensured this did you rerun genzaptelconf -dsv ?

    Tom
  7. TheShniz Guru

    Yes, more information is definately required...

    1.)

    All has not been well with Digium lately concerning Zaptel drivers... what release of Asterisk & Zaptel are you using?

    I ran into a strikingly similar issue here: http://www.pbxinaflash.com/forum/showthread.php?t=1643

    ...this was w/ Zaptel v1.4.9.2

    2.)

    I'm fairly sure, not postive, that the new TDM410's actually use the 'wctdm24xx' drivers and NOT the 'wctdm' of old... I never comment anything out of /etc/sysconfig/zaptel myself, but it's by no means going to hurt anything (a common suggestion).

    I'm almost certain -s & -v are no longer supported in Asterisk 1.4... you can run 'amportal stop' and then 'genzaptelconf -v' (for verbose) to detect the card as Tom said.

    3.)

    reboot just for the sake of rebooting, then run...

    amportal stop
    modprobe zaptel
    modprobe wctdm24xxp
    /usr/src/zaptel/fxotune -i 4

    ...this will tune your card per channel based on the noise/voltage on the lines.

    4.)

    I've never had the need to do anything w/ Zap Channel DID's and you can just leave it blank, but the gist of it is you can answer calls differently based on the channel (analog) the call is coming in on.

    X.)

    I should note that PiaF is most wonderfully compiled from source, and should remind you to follow the update-source instructions to grab the latest & greatest versions if you haven't already and are still experiencing issues.
  8. mkhurrum New Member

    Thanks Guys,
    I did install PBXIAF 32 bit, did go thru all the steps of update-source and ran update-scripts and fixes. Similar to what TheShniz has described in his earlier post, I cannot call out.
    I have included zapata-channels.conf and the zap show channels and status are okay.

    root@pbx:~ $ ztcfg -vvv
    Zaptel Version: 1.4.11
    Echo Canceller: MG2
    Configuration
    ======================

    Channel map:
    Channel 01: FXS Kewlstart (Default) (Slaves: 01)
    Channel 02: FXS Kewlstart (Default) (Slaves: 02)
    2 channels to configure.


    pbx*CLI> zap show status
    Description Alarms IRQ bpviol CRC4
    Wildcard TDM400P REV I Board 1 OK 0 0 0

    I will try a few other things and run genzaptelconf with -v option and report back.
  9. Bart Member

    Dude, you need to supply some CLI output or logs, otherwise you are making people just guess.

    But just for fun, add a 'w' (no quotes) to Outbound Dial Prefix in trunks. Then test.
    Can I assume inbound works correctly?
    What did you enter in outbound dialing?

    Bart
  10. Slamby Member

    Yes it does, as I found out trying to change the opermode. clicky

    I've got a 410 with 3 FXO running fine for calls in and out (that was the easiest part for me), though they're all set as a single trunk.

    I'd post you my config files if I knew which ones were relevant. :confused5:

    I'm currently running:

    Kernel 2.6.18
    Asterisk 1.4.21.1
    FreePBX 2.4.1
    Zaptel 1.4.11
  11. darmock PIAF Developer

    From man genzaptelconf on a current system :cool:

    NAME
    genzaptelconf -- generates zaptel configuration (TDM adaptors)

    SYNOPSIS
    genzaptelconf [-sRdvzF] [-c <country_code>] [-e <base_exten>]

    -d
    Also try to detect modules. Unloads all zaptel modules and loads
    them one by one. Considers a module useful if it loaded success-
    fully and if loading it has generated at least one zapata chan-
    nel.

    The list of detected modules is written as the value of ZAP-
    TEL_MODS in /etc/default/zaptel

    -s
    Stop asterisk for the duration of the test. The detection will
    only work if nobody uses the zaptel channels:

    * To allow unloading of modules

    * to allow reading configuration files.

    -v
    Be verbose. lists the detected modules if -d is used. Lists
    detected channls. In the end tries to connect to asterisk to get
    a list of configured zaptel channels.
  12. v0ip-Pete New Member

    Slamby & mkhurrum Hi-jacked my thread!!

    :mad5:

    It appears we all have similar problems thou :crazy:
    Has anyone managed to resolve it?

    Just checked and I am using the latest driver.

    root@pbx:~ $ lsmod | grep wct
    wctdm24xxp 114276 2
    zaptel 190852 8 xpp,wctdm24xxp
    root@pbx:~ $
  13. mkhurrum New Member

    I have been not been able to make it work consistently. Its strange that on my verizon lines it works fine - on ATT lines it does not. It might be that asterisk is dialing the numbers too fast - how do we slow it down?

    MK
  14. jmullinix Guru

    Try adding a couple of "w"s in the dial rules for your ATT trunk. The "w" causes a short pause before dialing.

    For an 11 digit dial it should look like this in the dial rules for the trunk:

    w+1NXXNXXXXXX

    If that does not do it, try a couple of more "w"s. You might also want to include:

    relaxdtmf=yes

    in your zapata.conf file.
  15. mkhurrum New Member

    Adding a w to the trunk prefix worked.

    Thanks all for your help.
    MK
  16. v0ip-Pete New Member

    mkhurrum:

    Can you tell me what you did to get it to dial out?
    (Since you hijacked my thread :rolleyes:)
    I'm stuck at

    -- Called 1/xxxxxxxxxxxxxx
    -- Zap/1-1 answered SIP/2003-09cceb68

    did you install an older version?
  17. Slamby Member

    Erm, I didn't hijack your thread, I was trying to help. I confirmed the correct driver, and offered to post my configs, though I don't know enough yet about the system to know what's relevant.

Share This Page